Image path from Blocs template not routed correctly


Being an avid Blocs user I’m very excited about the integration of Pulse CMS within my favorite builder.
Been testing pulse for a bit but running into some (newby probably) uncertainties.

I would like to give users full and easy control over a gallery included on the page. So I build this in blocs and include it into a pulse content container. But when exporting it into a template and running it on my server the routing to the images and thumbnails somehow get mixed up. I even tried it using the Portsmith free template on my server and it does the same thing. The Thumbnails ar not loaded correctly while all the image files are in the right location. Link to example:

Somehow I seem to struggle finding the right way of getting a template to work within pulse. I cannot find out what I’m doing wrong while the general use of pulse is so straightforward.

Any help/advice will be highly appreciated.

Your gallery refers to non-existent files.
“Content / media / gallery1 / file0001035576327.jpg”
Check script “timthumb.php” folder in the “Plugins” = I do not know.

Check out the website:
The images are in a different size = help.
If you are interested in the script, let me know.

I am a Blocs user as well, and since one month a happy pulse user to

did you use the version 2.3 beta10 of Blocs?
because i had the same problems and it was a bug in Blocs, I asked Norm, and he fixed it in build 10
maybe this helps, give it a try.

1 Like

Thanks for that @sandy - sounds like that is it :slight_smile:
Great site by the way @Dotzirk - looking good :slight_smile:

When done, you can send it to and let them know you used both:


@sandy Thanks for the tip! I did not use the 2.3 beta though, just the latest working version. Had a similar issue when using blocs in October cms. Norm is renown for his troubleshooting skills but I havent thought of it passing it to him. I might. It seems any image that is put in a pulse container within blocs is not routed correctly.

Yet another problem occurred now using pulse css. I can’t save any of the changes I make when in admin mode. Tried to set all permissions to files and folders but nothing works. Altered the .htaccess file as advised in the help section but nothing works. Running my site on a digital ocean vps.
Please advice cause frankly Im starting to regret my purchase a tiny bit…

@pulsecms thanks! but it is nowhere near done, just tinkering. When done I will submit it to the build with blocs people. But for now I just need pulse to be workable for me and my future clients.

1 Like


I havent thought of it passing it to him. I might. It seems any image that is put in a pulse container within blocs is not routed correctly.

hi, this is what I did all ready and there is an update for that, amongst a LOT af NEW features, the beta version is build 10, and very stable, you can download it, beside of the org blocs version.
tha problem is solved after that.

I can't save any of the changes

I hade the same thing in the beginning, first check you PhP version, should be 5.6 !!!
if its 5.6, the standart installation will work 100% ( or try local with MAMP )

I have to admit that its very important to play with the posibilities, and try things out, the pulse core is great and easy and fast, and if you dive IN a lot of things to adapt to your wishes, so dont regret for your purchase. just give it a try.

here are two projects of me, made with Blocs and CMS by Pulse
first project
I made some CSS changes for the design
Blog, picture and text upload by client. ( he is even doing it on his iPhone..)

2e project
site was Blocs and online for a few months, client wanted to be able to change all his pictures, and change all his text, I took the project off line and within one hour it was online again with CMS blocks inside. and up and running.

on the second project I used the slide from PULSE, ( not from blocs ) and also the pictures are the gallery function of Pulse.

from both projects is easy for me to change design, fonts color ect, and update it.
I hope this help.


1 Like

Thanks @Dotzirk - send me a PM with FTP access and will make a tinker for you :slight_smile:

This topic was automatically closed after 11 hours. New replies are no longer allowed.