Page layout issue on 5.1

This new site I am working on, we wanted to call the blog page recipes instead. So I made a new page called recipes and copied the code from the blog page onto it.
It works except that the page divs do not work. I have them set in the standard 40:60 ratio but my page shows it allin one column.

Looking at the code the only difference I can see is this:

on blog page:
<body class="blog-home page-template-default" >

and on recipes page:
<body class="Recipes page page-Recipes page-template-default" >

If thats the problem how do i fix that?
Or could I just rename the blog page without it breaking things?

It looks like your styles are not being applied to that page.

Pulse pages now add classes so you cane style individual pages differently with just CSS adjustments.

You could try:

Change your css styles to blog-home and apply them to page-Recipes - just find and replace in your theme’s style.css

But renaming the Blog page should work. But try above firstly :slight_smile:

It seems to me that the very act of going into that blog page to make any edits will somehow cause the thing to break;


Look at this - the source code says it should all work and on line 30 we have this:

body class=“blog-home page-template-default”

which seems to be right.

And yet it is broken. This happened to me on Pulse 5.03 so its not a new thing. Cannot remember how I fixed it before, I think I had to eventually nuke and pave.

Could you DM me here the password to that page again and will take a look?

Also - might be worth switching off the cache and saving

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

We can’t replicate the blog styles changing. We’ve tried renaming the page in pulse and on the filesystem. This ones is really puzzling. Unescaped newlines would cause problems in the JSON parsing.

Could have been a weird way in the upgrade, or the way added the content or other?

The custom layout seems to be wrong and needs to be updated. I suspect you might be seeing some javascript errors around missing JS files.

If possible, please update to Pulse 5.2BETA1 when available, and see if these appear again.

Cheers :slight_smile: