Big problem with gallery admin on 4.7

I have been working on this staging site all week:

and was doing some final tweaks before going live with it. And I discovered a bug that manifested itself when I tried to reorder images in the gallery.
It would create a load of dummy image placeholders that could neither be displayed nor deleted.
At first I thought it was because I was using a plug in for the gallery - but I changed the page over to the standard Pulse one and same thing occurred.

Here is what admin looks like:

The only way I can fix this is to delete all images in content/media/galley with an FTP program and then upload all again.

Never seen this before and I have a bunch of Pulse sites on my server which is a very modern and well behaved VPS

Anyone have any ideas?

Remove the “,” from file names. Maybe that causes the trouble.
… and some images don’t have an extension e.g.,-18ct-with-Pink-Tourmaline-
“.jpg” missing

According to the source code to create a filter gallery.
I do not know this particular script.
Send me plugin = gallery.php.
I tried to help.


The script does not work in Mozilla Firefox. Look here.
Look isotope page.
Gallery isotope pattern.

Try adjusting according to that model.


Thanks for your input on this. I think it is sorted out. All files did have .jpg extensions, but I went through all the file names and edited them to make sure that they were okay. A couple had commas in, which I took out, and one in particular seemed to be the culprit and the cause had a ampersand & in the name - and I believe that was causing the issues.
I normally name files myself according to best practice but these were all given to me by someone else.
Hopefully its all cleared up now.
And I have no problem with the minimalistic isotope addon in Firefox - it seems fine. Thats what I am using here.

1 Like