Blog setting issue


#1

Hi

I m having an issue with blog when clicking on the title or clicking on the ##more## read more resulting in an 404 error i have no idea how to repair this
at the moment i take off the read more.
where did i mistake ? please help

https://www.japanicelandsociety.net/blog/


#2

Please check that you added a htaccess file inside the blog folder as described here: https://instacks.com/pulsecmsstack/tutorial/#blog-htaccess


#3

Thank you so much mr Instack but i have no result
i m not even sure if it s well installed


#4

Sorry, I don’t understand. Maybe phrase in Japanese, Michael will be able to translate.


#5

Sorry, is it possible if someone can check my website ?
i have 2 website with the same problem.
everything is fine, very good cms by the way
i just need this 1 problem to be repair
what should i do now ?


#6

You should add a .htaccess file as described in the link I mentioned.

Please post here a screenshot of your added file inside the blog folder and the content of the .htaccess file.


#7


#8

Here is the htaccess inside pulse

Uncomment line 2 and 3 below if uploading issues via Media or Dropzone

php_value upload_max_filesize 20M

php_value post_max_size 25M

RewriteEngine On

RewriteBase /pulse

RewriteRule ^tagged/(.*)$ ?p=blog&blog_tag_name=$1 [L,QSA]

RewriteRule ^blog-page-([^-])$ ?page=$1&p=blog [L,QSA]
RewriteRule ^blog-([^-]
)+? ?d=$1&p=blog [L,QSA]

end points for embedding into non-Pulse sites

RewriteRule ^endpoint/(.*)$ end_point.php?item=$1 [L,QSA]

drop zone upload handler

RewriteRule ^dropzone_upload_handler.php$ dropzone_upload_handler.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?p=$1 [QSA,L]

Adds SVG image support

AddType image/svg+xml svg svgz
AddEncoding gzip svgz

block directory listing

Options -Indexes


#9

Hope all this can work


#10

Please, read the Pulse Stack tutorial again: https://instacks.com/pulsecmsstack/tutorial/#blog-htaccess

The bold text below requests you to add a htaccess file inside https://www.japanicelandsociety.net/blog/

Blog Integration
Blog htaccess File
The blog feature allows you to add a basic blog to any page on your site. This requires:

a service side .htaccess file in the folder of the RapidWeaver page
index.php as page name of the RapidWeaver page
To place a blog on a page, add a P5 Blog Stack, or use the default tag {{blog:"":"[[blog-content-loop(<> <> <> <> <>)]]"}}.

Add in the server side folder following .htaccess file by using a FTP application. Be aware that the .htaccess file might be hidden on your Mac and / or in your FTP application.

Exchange “blogpage” with the actual folder name of your RapidWeaver blog page.

RewriteEngine On

RewriteBase /blogpage

RewriteRule ^blog-tag-([^-])+? ?p=blog&blog_tag_name=$1 [L,QSA]
RewriteRule ^blog-page-([^-]
)$ ?page=$1&p=blog [L,QSA]
RewriteRule ^blog-([^-]*)+? ?d=$1&p=blog [L,QSA]


#11

Thank you for your answer

i add the .htaccess

but , i still have no result

RewriteEngine On

RewriteBase /blogpage

RewriteRule ^blog-tag-([^-])+? ?p=blog&blog_tag_name=$1 [L,QSA]
RewriteRule ^blog-page-([^-])$ ?page=$1&p=blog [L,QSA]
RewriteRule ^blog-([^-]*)+? ?d=$1&p=blog [L,QSA]


#12

it is inside blog folder


#13

See:

Rename

RewriteBase /blogpage

To

RewriteBase /blog


#14

Thank you so much Mr Instacks !!!


closed #15