Blog URLs Pulse 5

I’m not sure what I’m doing wrong with the blog, but the urls for the individual posts are not working.

I add a new blog post
Enter a number, like 1
under Meta, I enter a url, like Maintenance-Tips

The summary blog page displays the entries correctly, but to view that individual post page, it uses the url

which results in a 404 error.

Also the Preview button when editing that blog post produces the same url and error.

We’re working on some blog updates for 5.0.2

But I just created a new post, labelled it “77” and changed the title to “blog-title-99” and it made the link fine:

It shouldn’t be a 404 error. Maybe you could share some more info?

This is a development area for the site, but here’s a link to the blog page:

When I click the first blog title, I get this url, which results in a 404.

In the Settings, I have blog url set to:
and blog prefix is car-tips. I don’t know if that makes any difference.

In the admin blog section, the name is 5, Meta section, blog url is: Increasing-Fuel-Mileage

The documentation seems to be unclear as to what instructions apply to version 4 and what applies to version 5, so I don’t know if I’m supposed to edit the .htaccess file?

I can give you a login if you need to look in the admin.


Thanks @vwatson

The manual is Pulse5 only :slight_smile:

Please can you zip the site and DM it to me so I can take a look and can let you know what to adjust


Emailed you the site files.

1 Like

Thanks - will take a look and send you a mail back :slight_smile:

​The problem is that the blog is set up on a car-tips page by {{blog:car-tips}} So its really trying to use a blog prefix.

There are a couple of options for fixing:

  • create a car-tips sub blog and work from there (I think this is the best approach)
  • adding a rewrite rule RewriteRule ^car-tips-([^-]*)+? ?d=$1&p=blog [L,QSA]

​We’ll make this easier in future :slight_smile:

Fixed in 5.0.2! :smiley::+1: