Broken site updating from 5.2.2 to 5.3.4


#1

So I just tried to update a client site (very picky one) to the new version.
Usual process of FTP all files except content and template.
And I got blank pages. The admin works okay but I have no pages visible.
So I reinstalled 5.2.2 and its running again. What to do next? I am guessing a template or .htaccess problem.. Are there any key differences in page templates between these two versions? I am using a custom template btw.


#2

Very strange. My guess is that it’s some .htaccess error, since I experienced similar problems with another CMS. But it could have something to do with your template, too, so my suggestions are:

a) You could switch to a default template before upgrading to see if your custom template causes the error.
b) You could upgrade with your default template and then temporarily disable the .htaccess file to see what happens.

And, of course, make full backups before those tests.


#3

Great points @Torsten

Also:

  • with the custom template make sure you have the same basic tags as the default template
  • the htaccess file has changed between those versions - see the one in the download or sample.htacess file and use that

#4

Well it turned out to be my template after all. Fixed that up and it worked.
Blog doesnt work, but thats a different story.


#5

I experienced a similar issue. After installing version 5.3.5, all I got was a white page with error 500. But I was able to log into the admin area. Installing 5.3.4 worked all right.
And then, uploading the files of 5.3.5 over the existing 5.3.4 files also worked, but in the Dashboard -> Settings, I saw that the version was recognized as 5.3.4 instead of 5.3.5. Only after upgrading from the Dashboard (uploading a ZIP file), the version number was correct.

But now my settings were gone. The config.json must have been overwritten. I must say, I'm quite astonished that this file is placed in the pulsecore/storage folder, and not in content.

This all seems a bit mysterious to me, but fortunately I managed to get the installation running in the end. I am only wondering why I received that white page in the beginning.


#6

If you are manually updating, make sure you follow the instructions found on page 15 of the instruction manual:

Please upload all Pulse files except for:

  • template (folder)
  • content (folder)
  • pulsecore/storage/ (folder)

You won't over write your config.json folder then


#7

yes indeed @Raimo but it has been mentioned before that pulsecore/storage ought to be in a separate folder to avoid this kind of thing. It would make far more sense.