Cannot logout as an editor


#1

I created an editor, logged out as admin, logged in as such, but cannot logout as editor.


#2

Thanks @PeterSchmitz - so to confirm - when you press the logout for the Editor it is not logging out?


#3

Yep.
You go back to the dashboard. And cannot logout there also.

Also:
if I edit the rights of the usergroup Editors, and I select reading and writing at the Blog-page, but select no other page, then the only page they cannot edit is the Blog. It is counterintuitive at least. But I think it is a bug.


#4

Thanks @PeterSchmitz - we’ll take a look at this for a future update :slight_smile:


#5
  • I just created an Editor - logged in to dashboard and logged out to the “login page”
  • so it worked for me
  • if you can send in your logs (from admin > extend) we can try and see what is happening on your install

#6

Regarding this… that is actually a feature.

I mean, there are some users who want their editors to only edit the Blog. Some designers setup their clients with only blog access (not to be able to administrate / edit other parts of their site).

Is this something strange or you wanted something different?


#7

I select the blog to read/write, but after that they can not edit the blog but all other pages? So you have to select what you do not want to be edited?


#8

Thanks @PeterSchmitz

I think it’s the opposite…

Under “Editor” in “settings” you select the Blocks or the Pages you want the Editor to be able to see in the Dashboard, which includes what they can edit.

e.g.

Blocks

Pages

If it’s unselected it shouldn’t be appearing for them and that means they cannot edit it.


#9

I am not the right person for Pulse, I guess. It just doesnot work as you say. Sorry.
It hasnot a intuitive setup. Why are there two places where you can setup rights for an editor or whatever?
I try things out, and it dosnot do what I expect.
I am finished with it.


#10

This is a really strange bug @PeterSchmitz and might be something on your setup/install.

Have had another look at the editor user. I could change a page or block selected in the settings. Logout also worked.

I think we need a look at the configs and the error log. This is a strange bug. Could you send them to me in a message? I’ll message you and please reply to that

(go to Admin > Settings > Extend > Logs)

Thanks


closed #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.


#12

As we haven’t had the logs back, I’m not sure what to do. I can’t replicate this in testing at all.

We can:

  • Can login and logout as Admin and Editor
  • Can check and uncheck items and are appearing (or not appearing) correctly in the site