Can't get Pulse login screen to appear!

I’m trying out PulseCMS and I can’t get the login screen to show up on a test site.
Can someone have a look at and tell me what’s wrong?
I’ve tried setting the pulse_dir to ‘wmtl/pulsepro’, ‘pulsepro’ and others but I just can’t get the login screen to appear.

Thanks @imacken - the site appears to appear here?

Your login is
Maybe you fixed it?


Hi Mike,
Thanks, but, no it’s not fixed.The login screen comes up, but the password is just rejected. I get this all the time.
To be honest, the whole thing seems to randomly work sometimes and not others. It only seems to be when I test with a sub domain, e.g., in this case.
Whenever I try with a root domain, it seems to work ok, but following the docs for the path to pulsedir just doesn’t work.
The example we are looking at, has the pulsedir set to ‘admin’, but surely the docs suggest it should be ‘wmtl/admin’.
Also, I regularly get just a white screen in Safari rather than the login screen, but using Chrome for the same site sometimes gives an error.
I really want to understand why I am having so many issues, as I now have a couple of clients interested in what PulseCMS can do.
Biggest issue at the moment, is the password being always rejected. On the site we are talking about, the password is ‘demo’.

Now, randomly, I can access the login panel having changed nothing!
I really don’t understand what is happening here. sometimes I can log in with one browser, but not another, sometimes the password is rejected and sometimes it isn’t.

Now, I am not seeing any content in my blocks! When I edit the blocks on Pulse, the images just have a block with a question mark, even though the path in the HTML code is correct! The entire Pulse block just shows as having no content when I look at it in a browser.

The site Pulse is now and the p/w is demo.

On the simple test site itself, the Pulse block is the left hand one - the one that is blank!

I really need help on this as I am trying to demo this system to a client in a couple of days!

I’ll post this here in the hope that it helps other Pulse users faced with the issues Iain was experiencing. I’ve been helping Iain with his Pulse install and it seems that he was faced with two main issues;

  1. The log in seemed intermittent and would sometimes allow Iain to log in and not at other times.
    – The Issue was that the config file contained a set of curly quotes which I suspect upset the login. When Iain was able to update the value in the Settings section of Pulse (Classic) I’m assuming that it again failed to make the correction to the config file (again because of the curly quotes). Manually removing the curly quotes from the config file and setting the correct path to Pulse appears to have fixed this issue.

  2. Iain had uploaded a page to the site and had swapped out a section of the HTML for a block in Pulse. Iain’s confusion was that the block in Pulse had an image in it which looked OK on the front end but broken in the CMS.
    – Although not a Pulse issue as such it could confuse a lot of people new to the CMS. The original HTML as well as the block code both had the image path set to the image folder (in this case called Resources) which the editor in Pulse can’t get to because of path issues.
    The solution was to remove the image from the block code and re-upload it into the CMS using the Insert Image tool in the editor. This places a copy of the image in a location that the CMS can get to so both the editor and page on the front end can display the image again.

I’m not sure if it would help or hinder new users but maybe Pulse could use a setting to define the locations for the Media location in Insert Image > Choose? I had one client get confused when they couldn’t access galleries from this picker and being able to pick images from within the template could also be useful too.

1 Like

Thanks Tim, I have replied by email but I think it’s useful here too.
I’m pretty confused still!

  1. The config.php file was unedited by me, except where I changed the pulse_dir. It was the default one from the Pulse site.
    In addition, if I use the default one, it doesn’t work, i.e. with the pulse_dir set to “pulsepro” or “testcms/pulsepro”. It is not just this test that I have had an issue with logging in. Maybe the ‘curly quotes’ are in the default config file. Where were they located?
  2. The issue here is that when publishing a site in Freeway, the images go to ‘resources’ folder. I see that you have a path that is “/testcms/admin//data/img/uploads/“ for the image. Did you mean to have ‘//‘ between ‘admin’ and ‘data’? If not, then how is Pulse finding the image?
    I have had these test sites working OK without having edited them in Pulse, i.e. all the images showing up with “resources” as the path, and it is only when editing a block with inserting a new image, that the path changes to “…/admin/….uploads”.
    I have even tried putting “testcms/resources/“ as the path to the images in the current test site, but that didn’t work either!
    I can’t see it being practical to have to change the image path from the site default to a folder within the Pulse folders (or to re-insert all the images). If there are hundreds of blocks this would be unmanageable.

Thanks @TimPlumb for helping @imacken here

" "

@imacken are you on a Mac. Look at my quotes above here - they are straight
Your in your post above are curly.

Maybe this will help:

Having them on will upset any web building app or coding app (Coda, RapidWeaver, etc)

Did you see @TimPlumb's post on working with Pulse and Freeway?

Hope that helps!

Thanks Mike.
Yes, I am on Mac, and the curly quotes thing as pointed out by Tim, seems to have resolved my issue with Pulse.
However, I am fascinated by this topic.
To edit the config file initially, I was using Textedit as it was the default editor for FileZilla which I use for FTP stuff. That is when I was having all sorts of issues with logging into Pulse. I changed he default to a code editor, CotEditor, and everything was fine. Still, I don’t think I ever changed a quote in the config file, but I guess Textedit must have converted them at the time of saving. Yes?
If this is such a big issue on Mac OS X, I wonder why it is not more widely known, and most interestingly, why I have not come across the problem before now.
I have published quite a few web sites, and have around 11 apps on the App Store, so I am amazed that this issue has not become obvious to me before now!
Now, on the issue of the SysPrefs change you linked to above, it seems to not make any difference. With ‘Use smart quotes and dashes’ on or off, typing a " comes up curly in Textedit, so I am a little confused by that. Also, there is an option in Textedit preferences to switch off ‘Smart quotes’, but, again, that makes no difference. If I type in a " it still shows up as curly!

EDIT: this was the answer to the Textedit issue

With regard to your link to Tim’s post about Freeway, I’ll check that out a bit later. However, what I am confused by, is that I have had Pulse test sites working fine in the last week or two with the images located in “Resources” (as per Freeway default).

1 Like

Yeah it’s a funny one but I saw it a lot with users editing config files for other apps too.
It’s one of those hidden “helpful” features of OS X :wink:

This topic was automatically closed after 24 hours. New replies are no longer allowed.