Error while installing pulse 5.2 beta 4 with mamp on local host

Uploaded pulse, changed the htacces-file and run admin/install.php and I got this error.

Fatal error: Uncaught LogicException: Unable to find configuration file in /Applications/MAMP/htdocs/ Stack trace: #0 /Applications/MAMP/htdocs/ pulsecore\invariant(false, ‘Unable to find …’) #1 /Applications/MAMP/htdocs/ pulsecore\wedge\config\load_config(’/Applications/M…’) #2 /Applications/MAMP/htdocs/ pulsecore\install\config_update_json(’/Applications/M…’, Array) #3 {main} thrown in /Applications/MAMP/htdocs/ on line 12

anyone knows why?

Hi Bvdn

There appears to be an install issue with vs.5.2.4.

Check out my suggested work around at Pulse 5.2BETA4 Release / Latest coming next week. It worked on my localhost and a live server.

Please also note today’s posting from Michaels announcing the soon to be released vs5.2.5 further down in this post. He has noted that: FIX: Added a new safety check to raise an error if the old config.json can’t be backed up or doesn’t exist.

So the real solution is on the way!

1 Like

Thanx :wink: for your quick response

1 Like

I als tried pulse 5.1, the install is working great, but I get an error when I try to upload media:

Upload a media file

Notice: Undefined property: stdClass::$allow in /Applications/MAMP/htdocs/ on line 16

Warning: implode(): Invalid arguments passed in /Applications/MAMP/htdocs/ on line 16

Fatal error: Uncaught LogicException: A pre-condition has failed in /Applications/MAMP/htdocs/ Stack trace: #0 /Applications/MAMP/htdocs/ pulsecore\invariant(false, ‘A pre-condition…’) #1 /Applications/MAMP/htdocs/ pulsecore\pre_condition(false) #2 /Applications/MAMP/htdocs/ pulsecore\tags\Dropzone->generate_html(Array, Array) #3 /Applications/MAMP/htdocs/ include(’/Applications/M…’) #4 /Applications/MAMP/htdocs/ pulsecore\View->render(Object(pulsecore\ViewModel)) #5 /Applications/MAMP/htdocs/ pulsecore\page\admin\MediaUploadHandler->handle_get(Array, Array) #6 /Applications/MAMP/htdocs/ pulsecore\page\Base->process(Array, Array, Array, ‘GET’) #7 /Application in /Applications/MAMP/htdocs/ on line 12

Am I doing something wrong?

Hi again.

I am no expert at resolving Pulse errors so can’t help from my limited experiences but here’s what I would be checking if I had the same error.

To me the clue is your first line of the error message - Notice: Undefined property: stdClass::$allow in /Applications/MAMP/htdocs/ on line 16.

I have looked at the media_upload_handler.phtml file and on line 16 the code in my v5.1 code is about ‘allowed_file_types’ so I would recommend checking on what media file types you are uploading. I would expect a JPEG file to work. From what I understand the following types are default uploadable - txt, jpeg, gif, jpg, svg, png, pdf, zip, csv, xls, xlsx. If your file type is not in the list you would add them in the Settings page.

Happy trying - if I am totally wrong let me know cause that’s how I /we learn.


I fixed it <my entry 1 / pulse 5.2 beta> , made a mistake in the layout.php,
misplaced the <?php echo (isset($parsedown) ? $parsedown->text($content) : $content); ?>
Forget Entry 2 / pulse 5.1

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.