German umlauts and spaces disappear in the navigation


#1

Hi, I’m new to the forum but a great “old” pulse user (V 1.3, 2011). I love Pulse and I am very happy that it is so alive.
Now I have Pulse 5.2.2. freshly installed and converted into settings in German (https://www.stilklar.de/test-cms/, login is unchanged) but found some questions or mistakes.
We here in Germany also often use umlauts or two words in the menu. So I created a new page “Über mich” (About me) and added it to Settings / Navigation. But umlauts and spaces probably no longer work, it is now “Bermich” … very stupid;)
Is this a mistake or do I have to adjust something? I think it was already in an earlier version.
Thank you for help and sorry for my bumpy English


#2

The page name can not contain a space.
Create a “ueber_mich.txt” page,
edit the page name in the navigation settings.

Explanation is here:


Related posts:



#3

Great to have you on the forums @annett :slight_smile:

We wouldn’t have reached 5.2.2 without all your fantastic and constructive feedback reports!

Can you try the suggestion by @IvaRo and let us know if it works for you with German Umlauts?

Create a “ueber_mich.txt” page,
edit the page name in the navigation settings.

Thanks!


#4

Thank you, IvaRo, that helped me a lot !!!
I have the lines as suggested in filter.php
229 and 271 (’/ [^ a-zA-Z0-9_]
supplemented with (’/ [^ a-zA-Z0-9_äÖÜäüß]
and it works perfectly.
Also, the note to adapt the “home” page to the German habits “welcome” is great.
I’m glad to have finally logged in to the forum and hope to cope with the new matter.
Once again many thanks.


#5

Sounds great :slight_smile:

The “home” page breadcrumbs is ready for 5.2.3:

Other changes coming soon :slight_smile:


#6

Strange phenomenon … :roll_eyes:
After my image tests, I found that after a while editing in the pages and blocks, I can not change anything. After saving the file came again and again, what was there before. I could not upload pictures or change texts - very strange. I looked for permission first, got newly created files 644, should be ok ??? A look directly at the server then showed me that the file was duplicated in the parent folder created (

Summary

Yesterday I once again tested very intensively, Pulse several times completely reinstalled on my server, in between times the PC restarted, browser cache deleted, …, pages and blocks with and without “-” created, navigation updated and repeatedly the same problem had. Of course, the link in the navigation then went to 404th I also tested with the filter.php - with and without change. Always the same result.
In Pulse 5.2 I created page names with “-” that are correctly linked in the navigation, but “-” is invisible - that’s how I like it.

).
Is it on my server or can it be that there is an error here? Would you like to test that? That would be very nice, thank you! :blush:


#7

Thanks @annett - I’m not too sure on these errors you are having but we are going to make Umlauts work for 100% in the next update, is this the issue you are having?


#8

That would be really great, thank you!
Well, I do not know why Pulse saves the files to another location, maybe it has something to do with the fact that I created a new file with a hyphen in the filename “-”. But under blocks / contact there is contact-right.txt, so also with “-”. Changes are saved in the wrongly stored file, but the navigation link goes to the right file.
It would then have to be tested again with the new version.


Pulse 5.3 is here 🤩
#9

Done some more testing on this and the changes we’ve already made in the next version should fix this!

  • Strings with ß and ü are not changed so UTF-8 aware filtering is working for sub menu names.
  • Filename filtering was updated for UTF-8 too.
  • It does need the underlying filesystem to be UTF-8 aware though.

Thanks and more on this soon!


#10
  • This is added as an option in the next update (5.2.3)
  • Allow other pages than home to be used via Settings in Admin
  • Create a page with the title you want
  • Select it in the settings and it will be the new Home

#11

That’s great and very helpful, thank you.:smiley:


closed #12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.