Link module WYSIWYG not working correctly with HTTPS


#1

hi guys,

when i try to enter a HTTPS link the WYSIWYG removes the “s” after saving the block.

workaround: enter the s manually in HTML-Code View.

using pulse 5.0.1


#2

Confirmed - I see that too - must be Redactor over-riding the link.
Assuming the http site has redirects to https:// it will be ok, but this needs a fix.

Cheers


#3

@squareclouds-design

The link bug seems to be a redactor thing. The demo on https://imperavi.com/redactor/ shows the same behaviour… I cant see an API setting to change this this.

I’ll log a bug with them and hope they bring out a fix in a future version :slight_smile:


#4

Thanks again for your report.
It’s definitely a bug. They’ve added this issue to their to-do list for the nearest update.
So when it’s released we’ll get this in the Redactor update

I’ll close this here and add to issues:


closed #5

#6

Fixed in Pulse 5.1 with Redactor 3.0.5 onwards