Metadata Issues On Pulse Templated Blog

I’ve been having issues with my blog for a while, and while some of those issues have been fixed, the biggest issue I can’t seem to figure out a fix for, or get help to fix, which is a metadata issue on my blog. The issue prevents me from being able to share any of my posts via social media properly.

First off, I apologize if this gets a bit lengthy, but there is a lot to it that I’ve discovered that just puzzles me more and more, so I’m including it all in the hopes someone can help. My site is a mix of templated with Pulse, and not templated. My home page, which is not associated with this issue is templated, and my blog of course. That is where the issue lies.

I have overridden some of the default settings in the admin settings on individual posts, but that doesn’t fix the issue, only some of the metadata changes. While the title seems to be correct, the meta name is set to “author”, and the content to “PulseCMS”, which it shouldn’t be, but the meta description seems to be custom, and the keywords seem to be correct. This metadata is in the head tags, and that is what changed when I did the override on an individual blog post.

This seems to be pulled in by the code I placed in the template <?php echo $page_title; ?>, and <?php echo \pulsecore\get_context()->theme->meta->render(); ?> , which I placed underneath the meta keywords at the top of the template. (See screenshot below)

Screen Shot 2019-11-20 at 4.09.38 PM

But there is metadata being pulled in with the OGP PLACEHOLDER tag in my blog template. This is where it gets a bit messed up. The part of the screenshot under “Open Graph meta data”, while the title and url are correct, the description content is not, and the messed up thing is, I can’t find anywhere in Pulse where that description exists. So I still have not been able to figure out where it's pulling from. I also can’t seem to change the OG image either, the default image won’t override no matter what I do.

Then when you see the “Schema . org meta data” and “Twitter card meta data” sections again, the description content is the same thing that I can’t find anywhere in my site, and have no idea where it’s coming from. As well as the default image that won’t go away. (See screenshot below)

I can’t figure out where within Pulse the OGP PLACEHOLDER tag pulls its information so I can override it. If it helps I took a screenshot of the admin settings page that shows the OGP, blog settings, and RSS settings. (See screenshot below)

After not being able to figure this out, or get any help to figure it out I tried to delete Pulse from my server, and uploaded a newer version of Pulse. I was using vs 5.2.2, but the newer version is 5.3.2. After adding the new fresh version I then added my content and templates. Unfortunately, this did not fix the issue. So that leads me to wonder if the issue lies within the setup of the template for my blog page.

Screenshot for the page header, see below:

Then the body where I'm calling the blog content:

For the blog page in Pages in the Pulse dashboard I have the blog content setup like this:

Inside a blog post I have it ordered like this at the top of each post. The first part is the image I’m pulling in for the featured image, then using the OGP to try and ensure the image is used as the featured image. Then my social sharing toolbox, and the blog content.

What I notice though, which has me wondering if something is not correct, is when I look on my blog page that displays all my posts, I noticed that the code for the featured image is blank, and the image itself is displaying in the blog content. I’m wondering why the featured image div tag above the blog title has no content. (See screenshot below)

I also noticed something else that’s odd. In the head tag of an individual blog post I can see the correct title, the correct description, although it’s doubled. I’m not sure why the author content comes up as “PulseCMS”. Or why there is a meta description, then the author with content “PulseCMS”, then another description, and then the robots follow to follow and index that page. I don’t know, that order and the author content make no sense to me. Maybe someone else can make sense of it, or maybe it's just me? (See screenshot below)

But what I really find puzzling is what is displaying at the top of the body tag. (See screenshot below)

Those are the keywords inserted into the keywords section in the dashboard within that individual blog post. But the keywords are in the body tag for one. The other puzzling thing is all the content that seems to be stored inside that meta keywords tag, content that should not be inside that tag at all, but when I open that tag in the inspector, all the page content is inside it. Very confusing.

What it contains are the links to the CSS for my blog posts, the FB and OG meta data that is all messed up, and I say messed up because it contains the meta title “Rachel H Kay Blog” title that should not exist on an individual blog post, as well as the description “Welcome to the blog of Rachel H Kay…” that should also not exist on an individual blog post. This title and description is what I can’t locate anywhere, and have no idea where it’s pulling from. It’s like it doesn’t exist, yet it’s there. Then what follows after that is the other metadata like Twitter.

I honestly do not know where all that incorrect data is pulling from, or why it’s in the body tag and not the head tag.

Then what’s worse is the keyword meta tag also has all the blog content inside it, the actual blog post itself is inside that tag. As well as my footer code, and the JS script links at the bottom of the body tag, below the footer. Then after going through all that content I find the end of that meta tag: (See screenshot below)

This is the blog post I took screenshots of all the metadata,

This is the meta keyword tag that I customized in the blog post that has all the content, including the custom meta description.

Screen Shot 2019-12-11 at 12.07.42 PM

It’s a total mess, and I’m completely lost as to the cause. If anyone can help me figure it out I’d truly appreciate it, because since this issue popped up, which began a while ago when I first upgraded from vs 3 to vs 5, my blog is utterly useless because I can’t share any of my posts via social media. I’ve tried upgrading to the other versions, but vs 5.3.2 is the most recent I have. I can no longer afford to pay for Pulse, so I haven’t been able to upgrade. But seeing how no matter what upgrade I did since the first upgrade, the issue persisted, I doubt upgrading again will fix anything.

Hi @RHKay!

Thank you for spending your valuable time to provide us with a detailed description and explanation of the issue you're having with your blog.

I've forwarded this to our dev to have a more in-depth look of what's going on and what's wrong.

Could you also send me a copy of the error logs from your Admin panel?

I'll get back to you as soon as I receive a feedback.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.