Navigation problem in 5.3.5


#1

hi guys,

after finishing my page with 5.3.3 (with the map-tag bug) since i decided not to use 5.3.4 cuz it had some blog bugs, i now have to make another page and i wanted to use 5.3.5. i am having problems with the navigation though. i cannot change anything in the admin area. if i delete pages, the navigation updates, but if i want to deactivate items or create new items it does not save. all other admin settings are saved when changing them (like language or default template, etc), so i dont think this is a rights problem. if i change the json "by hand" the front end updates the menu items, for example i left only 3, but in the admin area still many pages are showing. someone having trouble like this? i didnt have problems with my website running 5.3.3.

EDIT: almost forgot – i am using a test subdomain ("update.xxxxxurlxxxxx.com") so i changed the htaccess to stop the https riderect, since the subdomain does not have SSL. not sure if this is important or not for the navigation functionality

thanks & cheers
santiago

PS: i kinda get a feeling posts arent being answered for a good while now :-/


#2

hi guys, me again,

still no answer, sadly.

i installed now 5.3.3 and with that i realised it has something to do with the server. my 5.3.3 website runs fine. the 5.3.3 i am working on works fine on MAMP (i can save the navigation settings) but on the other server it does not save the info. whats happening:

  • i change for example the order of the items
  • i press save
  • it reloads, but when i go back in the nav-settings everything looks the same
  • the config.json shows something different though. the frontend shows also sometimes updated elements, but in the backend, as i said, the list is still the same (i think it loads the pages files alphabethically but then doesnt check the config.json to check for settings)

i already changed all permissions to 777 to see if it works like that, but nothing. i change the php to 7.2 (was 5.6) but still nothing. when i deactivate php boost, the "save" button in the navigation settings does not work (no submit is sent). this is everything i found out today. i hope someone can give me a hint. it is a shared webserver, on the install page it says everything should be fine :-/ so i am clueless.


#3

Hello @squareclouds-design, your problem is probably the cache in the server. I also have this problem sometimes. First nothing changes and then, a few hours later everything is as it should be.
You can clear your browser cache with Ctrl + F5. How this works with the server, I do not know. Maybe you can adjust something in the server interface or ask your provider.


#4

thanks annett. i dont think it is cache, it would be wierd that only the navigation settings page gets cached. if i change anything else in the settings, it gets changed right away (laguange, default template, username, etc). i think its something with the page

index.php?p=manage_navigation

something there is not loading the JSON that actually has the right values saved (under pulsecore/storage/config.json).

client side caching has also nothing to do with it i am affraid, i have hard and soft refreshed many times :-/ both the frontend and navigation settings page

thanks for the reply though! it is so quiet here that any help is welcome!


#5

That's right, it has become strangely quiet in the forum and I'm starting to get worried.
I just tested Pulse 5.3.5 locally. I need the feature with the sub-blogs. These are not in the version, so I'm currently at 5.3.2 remained that works so far. But yes, I have found a number of bugs at 5.3.5 and I think there is a basic problem with some paths.
Did you try to change directly in the .json and directly on the server?
On my server, only the .htaccess is affected by not being updated. I can handle it by directly in plesk (server) logged in and change there. Yes, strangely.


#6

How do i get 5.3.2? I could use a version that actually functions.


closed #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.


#8

Hey Guys, we know that it's been a while since you've discussed the issues raised by @sean on our previous versions. Just to confirm, have you already updated to our latest version and still experience this?

Also, we encourage you to log any further problems that you might encounter in our GitHub.

Thanks!