No pages visible in 5.2b4 new site

Just deleted all the old 5.1 files on my test site. I found that in place the update button would not work, so I decided to nuke and pave.
Uploaded all 5.4 files with ftp, then went and found a copy of the missing config file and uploaded that and I have a 5.2 site.
However I have no pages. The standard about/work/blog/contact pages are not there.
If I add a new one and enable it in settings/navigation, its not there either although the new page called Test does show up onthe Navbar.

Any ideas what is happening here? Its all a bit broken.

You could try:

Yes, I know that link doesnt work - hence the query!
Yes, pages exist in admin. Also I can see them in pages folder in ftp looking at the site.
Yes, admin settings saved.
What next? I have tried deleting all and uploading and installing again. Same result.

Solved - I figured as pages we there it must be a direction issue. Sure enough it was down to .htaccess not being there.
It seems that the default install does not put this in place. Only an example one. Might be worth pointing that out in the documentation as I have not come across it before. But it is a beta I guess, so a few things missing still.

1 Like

Great will add to docs and will ship with the “hidden” .htaccess and the sample.htaccess :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.