Problem with forms and email delivery

Recently I have had a couple of clients saying they are not getting email sent by the forms app. I host sites on my own VPS and before setting a site live I check the form by getting it to send to my own business adress as well as my Gmail and Yahoo address.
I then change the name in config.php to theirs and ask them to check that they receive.

Sometimes this stops working and it seems to be because email services on shared hosting platform changes its boundaries from time to time. I spoke to the sys admin that runs my server and he mentioned this:Shared hosting uses sender verification.

So as far as it is concerned, the message might be a phishing attack as it claims to come from but in reality is coming from

We started using forms because having your email address on the contact page was a sure way to get your address harvested for spammers. Now that the form scripts have become more complicated they seem to be causing problems.
With two clients I have just removed the form and started using an email link using Tim Plumbs excellent little antispam app. I cannot be doing with clients calling and moaning that they are not getting email.

I think that this could be fixed if we were able to set a legitimate “from” address in the form.php script. It would be set to the actual email address of the domain that it was to be deployed on.

I guess this is possible - anyone know where and how?
Thanks, hoping we can get this sorted.

Oooh I am having the same problem since a client changed mailhost, they now use Kerioconnect with SPF DKIM and DMARC, and whatever I do, whatever form I use, how carefully I fill in all the smtp data, it will not arrive.
The ITperson who owns the server is still looking at it.
So I cant’t help you, only maybe this s somewhat helpful?

Same. I was using Just Forms however. It seems it would send successfully to some mail servers (Gmail or Google Apps had a 100% success rate) but it was spotty with others. I had a client who uses for their email hosting (yikes, I know) and they couldnt receive any emails. Unfortunately I had to abandon Just Forms and use JotForm instead.

Sending email from your own server is a nightmare. It might not even be Just Form’s fault. It might be some settings in my VPS or mail software. I dont know but I figured Id just let JotForms (or Wufoo is another good one) do the heavy lifting.

I use (superformbuilder by the way, does everything you could even ask for) lately, succesfull with exchange and all other emailservers except this emailserver that is encrypted with DMARC.
I will check out JotForms too. Hope I hear of the the solution soon!

Great feedback here guys (@mary, @pyxal and @jdloudon)

We’ve recently upgraded to Mailgun and have added all DKIM and other verification so deliverability should now be solid to even yahoo (not just GMail). Please have another check and let us know. If you are still having problems, DM me an email address and can test it on the logs :slight_smile:

I think it should now be a lot more reliable. Be interested to hear the results!

1 Like

Thank you Michael
What components do we need to install to get this update?

1 Like

Thanks @jdloudon - Should all update on our servers so should be good to go from now :slight_smile:

hello guys,

i am still having trouble with this. actually, to be honest, i had the same problem with my registration here in the forum as well! when i tried to register with

(or any other work email i didnt get any notification email at all! i of course tried it many times. then i just used my personal hotmail email adress and i could successfully register to this forum.

now i need just forms to work for a client website, but when i test with my emaill accounts, i dont get any notifications either. my hoster is 1&1 here in germany. any ideas what the problem is?

Thanks @squareclouds-design - it seems in the mail logs (we use Mailgun) that it’s not going through and there are some misconfiguration possibly of your email inboxes DNS somewhere - I’ll DM you logs then let’s go from there!

hi michael,

thanks for your message, i will reply there and not here in the forum

1 Like

Fixed in 5.0.2! :smiley::+1: