Problem with PulseCMS 5.3.9 >> ERR_TOO_MANY_REDIRECTS


#1

When I copy the PulseCMS 5.3.9 file to the host server and then do the install with [websitename]/admin/install.php I get the notification that "This page is not working", {website} has redirected too many times, try to delete your cookies, ERR_TOO_MANY_REDIRECTS. Whatever I try, delete my cookies , nothing works. The message keeps the same.
I made a ticket to my hostprovider and they came back that the lines"

ensure HTTPS - comment out lines 10 and 11 if installing locally without an SSL certificate

RewriteCond %{HTTPS} off
RewriteRule ^/?(.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

are not necessary, because the forcing of HTTPS is already done by there system of the Hosting Provider.

The .htaccess file contains:

Uncomment line 2 and 3 below if uploading issues via Media or Dropzone

php_value upload_max_filesize 20M

php_value post_max_size 25M

RewriteEngine On

RewriteBase /

ensure HTTPS - comment out lines 10 and 11 if installing locally without an SSL certificate

RewriteCond %{HTTPS} off
RewriteRule ^/?(.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

draft blog pages

RewriteRule ^blog-draft-([^-]*)? "index.php?p=blog-draft-$1" [L,QSA]

RewriteRule ^tagged/(.*)$ ?p=blog&blog_tag_name=$1 [L,QSA]

RewriteRule ^blog-page-([^-])$ ?page=$1&p=blog [L,QSA]
RewriteRule ^blog-([^-]
)+? ?d=$1&p=blog [L,QSA]

end points for embedding into non-Pulse sites

RewriteRule ^endpoint/(.*)$ end_point.php?item=$1 [L,QSA]

drop zone upload handler

RewriteRule ^dropzone_upload_handler.php$ dropzone_upload_handler.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?p=$1 [QSA,L]

Adds SVG image support

AddType image/svg+xml svg svgz
AddEncoding gzip svgz

add audio/video support

AddType video/mpg .mpg
AddType video/ogg .ogv
AddType video/mp4 .mp4
AddType video/webm .webm

AddType audio/mpeg .mp3
AddType audio/ogg .ogg
AddType audio/mp4 .m4a
AddType audio/wav .wav

block directory listing

Options -Indexes

After deleting the "# ensure HTTPS..................................", I get the error message HTTP ERROR 500.

What is wrong here? Do I something wrong? I only have copied the PulseCMS files to the server and I can't install it because of this. Please help?

With Regards,

Jeroen Kotterlink


#2

.htaccess errors take a little sleuthing to find what your host doesn't like... Sounds like they have some things already set, that this htaccess file is also trying to set...

  • Try renaming your your htacess file to something like bkp_htacess which will stop it from loading (but keep a backup of your settings)
  • then if your host doesn't automatically create a new .htaccess file, create a new one, but "comment out" (use a # at the beginning of the line) on lines like 10 and 11
  • and if it still doesn't load, try "commenting out" other lines as well

#3

Hello Riamo,
I tried all the things you mentioned but nothing helps. I expected that you, the provider of PulseCMS, could fix the problem. The error keeps the same, too many redirects or http error 500. I don't know what has changed the last few months, but I had the PulseCMS working in the beginning of 2019 or is the change to PHP7.3 something that has influence on it. I am not able to use PulseCMS for the last 6-8 months so I expect that the period I paid for will be extended until we solved the problem. Hope you can help solve this problem.
With regards,

Jeroen


#4

Hey Jeroen, I'm just another user of Pulse, like you. I just try to help where I can, as I have Pulse on a bunch of sites.

Generally, a "500 error" like this is an issue with your hosting and your .htaccess being in conflict... But can be other things as well (I have run into "500 errors" on WordPress installs in the past that had to do with memory limits placed by the hosting service...) They can be frustrating to troubleshoot, but a with little googling, and help from your hosting service, usually solves this...

Recently, I had issues with a hosting service and PHP 7.3 that was breaking all my websites (Pulse, WordPress, RapidWeaver, etc.) By backing the PHP down to 7.2 everything worked fine again. Turns out, they messed up on their implementation of PHP 7.3...


#5

Hello Raimo,
thnx for your answer. As I read I think the problem is PHP7.3. The problem is that the only PHP version available is 7.3. A downgrade to version 7.2 or 7.1 is not possible anymore.
Therefore I hope that issues can be solved by PulseCSMS.
With regards,

Jeroen


#6

You are missing the point...

  • Pulse works fine on php 7.3 - I had a problem with one host, but working fine with other hosts and php 7.3
  • The problem is probably with your .htaccess and your host...

#7

Hello Raimo,
Thnx for the info that php 7.3 is not the problem, but I'm not a experienced person to understand the .htaccess file and therefore I do not really know what to change to let the PulseCMS work.
By the way, did you changed the standard .htaccess file that's installed with PulseCMS?
Thnx sofar.

With regards,
Jeroen


#8

Let's start with what your hosting company asked you to do;

  • did you "comment out" (or even just delete) the redundant lines in the .htaccess files (add a # at the beginning of the lines to "comment out" any command you don't want run in your .htaccess files)

It looks like the https lines in your .htaccess may be causing the issue. Your host company is already forcing the use of https, and you are asking the browser to force it a 2nd time, causing the loop "ERR_TOO_MANY_REDIRECTS"

Depending on the how/where I have Pulse installed I sometimes add a lot of stuff to the .htaccess file. If the Pulse install is in the root folder, I add speed tweaks, 404 info, expires headers, etc. But if the install is in a "sub-folder" (like when using RapidWeaver) I leave the default .htaccess file alone, as I don't want to create loop errors like the one that seems to be happening for you.


#9

Thanks @Raimo for helping @Jkotterlink1964 with the great advice.

In a localhost test running PHP 7.3.1 (MAMP):

For example on localhost I don't have SSL installed and uncommented those lines added a "#" and ran the installer and it worked fine

If you are getting a HTTP ERROR 500 then something else is wrong on the server