Pulse 5.2BETA4 Release / Latest coming next week

Pulse 5.2BETA4 update

Hot on from BETA3 we are diligently beavering away on BETA4. Whilst it’s not released yet, I wanted to give you a little update on its progress so you know where we are.

These are the things already done:



  • Switched over some code to non jQuery
  • Date of last revision added to policy/T&C tag
    NB this defaults to the last time the file was changed if the third tag parameter is not present
    Thanks @ArmendHajdari
  • Added an intermediate step to the Pulse install updates process that lists the files that will be overwritten. The .htaccess and anything in the content directory are flagged
    Thanks Annett


We still have another 20 odd things to add for the final release of Pulse 5.2 but these are already in BETA4 and there might be more before that release but will keep you updated :slight_smile:

This version will most likely be released soon (this week or early next week) with the final version slated for end November/early December :+1::santa:

This has been released!! Yay! :star_struck::+1:

Get it from your dashboard and update today :slight_smile:

Installer is not working. I had 5.2 beta 2 installed. I forgot my password, and the reset didnt work so I deleted all files and uploaded a fresh 5.2 b4 and did the usual domain.com/admin/install.php
It looked like it was running the sequence, and then I just got a blank page and could get no further.

any ideas?

Have the same problem! Folder 5.1 = 63,3 Mb . Folder 5.2b4 = 17 Mb. There are not needed files in archive

I think that the new version is a much smaller install, so that may not be the problem.

i cant install it from scratch neither… error 500.

I wrote to Michael 3 days ago to notice this, maybe I should have used the forum.

Sorry for being slow to also report that on day one of this release I came up with the same install not working on localhost or on live server. Here now is my discovery & work around for what it is worth!

The error report I received from my localhost install indicated:
Fatal error: Uncaught exception ‘LogicException’ with message ‘Unable to find configuration file’ in . . .

I am not a coder able to interpret where the installer “stopped” but noticed that the config.json file was missing in the pulsecore/storage folder. In frustration I copied over from my config.json file from a v5.1 install - re ran the install again and it worked after refreshing the installer.

I then logged in using “my” password - not “demo”. It worked for me so hopefully for others this is an interim to test this release!

To you Michael: “In future can I ask you to indicate best way to report “bugs”, hiccups and possible interim solutions between releases so that we are all aware of possible gremlins. Do we use this forum? Do we use https://github.com/yuzoolcode/pulsecms-tracking/issues? Does sending you a personal email get through best?”

We cheer you on and together our shared experiences only enrich this great product! Thanks!

1 Like

Thanks @AceTutor that's helpful

Yes - this seems an error that crept in without a config.json already present.

I think it's another permissions bug. I don't think the web server can add/update the configs without it. So we have added a new safety check to raise an error if the old config,json can't be backed up or doesn't exist.

Thanks for your question and yes here is the correct place to report bugs:

It's hard to keep up when they come in via Twitter, email and forums - so best to keep in one place. Although the forums we can discuss too :slight_smile:

We cheer you on and together our shared experiences only enrich this great product! Thanks!

Thank you that means a lot!! :heart_eyes:

Im not sure this is related. The trick of copying the file worked for me.

But as on 5.1 version, the blog page returns an error 500 for me.


I have the same issue on beta 4.

Anybody else can give a try on a clean install?

1 Like

Thanks @Roberto - please add the logs from the Admin > Settings to the GitHub Issue, thanks :slight_smile:

Glad to see some movement on this. So where does this leave us? What is the current solution for reinstalling or fresh installs of 5.* Pulse?

edit: copied that config.json over from another of my Pulse sites that worked. And now I could install again on my test domain and it worked.

Except I have no pages except index. All pages exist in the pages section as per usual, but click on a page in menu and get a Page Not Found error. Cant see why that would be, unless its something to do with the config file.
Looking at the site with ftp I can see that the usual pages are there in content/pages, about.txt etc
But they dont work live.

Its worth mentioning that on a fresh install there is no navigation items inthe nav bar - to see them you have to go into the Manage site navigation area and hit save, for some reason then they show up.

1 Like

I have discovered that I have to switch theme from pulse settings- extend and save to get the blog working.

After this I can set the default theme again and seems to work fine.

1 Like

Following on from @AceTutor as mentioned above..

The support/help flow is now done better:

With clear place to find the Manual, report a bug (Github) or have a discussion (this forum).

The articles/docs are also archived on that page as PDFs and we will be moving away from that docs portal to streamline with the above 3 options. This should be much better :slight_smile:

Next BETA is doing well and things finished so far:

Pulse 5.2BETA5


  • Allow users to change the avatar from the Admin Settings (rather than just Media folder)
  • Redactor updated from 3.1.4 to 3.1.5



  • Added a new safety check to raise an error if the old config.json cant be backed up or doesn’t exist
    Pulse 5.2BETA4 Release / Latest coming next week - #9 by AceTutor
  • Regenerate the json config if needed
  • Selecting/unselecting delete and activate in Navigation Menu Settings now sets the menu items too. Save works correctly
  • Drag and drop images order in Media is now working correctly
  • Fixed Footer showing JSON on install. The fix is to ensure the template parses footer blocks instead of just including them. So use {{block:copyright}} instead of including it.

Release date to come...

Thanks @Roberto - we will try and replicate that way

Thanks @jdloudon - the missing config.json will be fixed in the next version for smoother installing. And yes it’s necessary to build the Navigation in some cases. That will need to be built anyway as the demo site pages are just for the demo.

More updates soon, thanks everyone!

The next update / release should be out next week :slight_smile:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.