Pulse Admin area very slow

Does anyone know what would cause my Pulse Admin area to become very slow and unresponsive. At first I thought it might have been an internet connection issue so I rebooted my Router but it made no difference. I installed Pulse a couple of days ago onto my server and until today it has been fine, but now doing anything in the Admin area takes ages like moving from one folder to another is like wading through mud.
Any help or suggestions would be appreciated.

Not seen this before and usually lightning fast - can you check on the installation docs about the diag.php and let us know the server configuration?


If it has now become slow maybe something has changed on the server and could be the case to check with the hosts also of the config.

Here are the results from the diag.php:
Pulse CMS Diagnostic Tool

System Requirements

Basic system requirements are an apache server with PHP 5 installed.

Server Type: Apache/2.4.18 (Unix)
PHP Version: 5.3.28
File Uploads: On
Safe Mode: Off
Magic Quotes: Off
GD Support: On
Zip Extension: On

Permissions Check

Folders should have at least 755 and files 644 permissions.

content - 0755
content/blocks - 0755
content/blog - 0755
content/media - 0755
data/pages - 0
config.php - 0644

Path Setting

This is where Pulse is installed. If you installed Pulse in the root, it should should a blank space. If you are using Pulse inside a sub-folder, it shoud be set as “/sub”.

Path Name: " /pulse"

.Htaccess Check

The .htaccess file is required for Pulse to work properly. If the file is missing, use the sample.htaccess file. Just remove the sample part and place it in the app root along with the index.php and config.phh files.

The .htaccess file exists.

Session Handling

If sessions are not working properly, it can cause problems with logging in and viewing blocks, etc.

Your hosting supports sessions

Hi Micheal,
I’ve fixed it. I found there was no .htaccess file in my server root. I added one with the following:


Now everything is speedy.


1 Like

Wahoo!! Great :slight_smile:
Thanks for sharing…

Hi There!

I’m having the same issue. I tried adding the v7 PHP line to the htaccess, but no luck. This happens on some of our sites and not others.

Any thoughts?

Thanks - what have you tried already. Can you list it? The sites were it is working… are these on the same server? Do they have the same config setup?

See above talking about permissions and what does the Pulse CMS Diagnostic Tool show you?


I had a similar issue once: slow admin which was fast at first.
When I accidently disabled the autobackup feature all worked way faster. Then I found out that creating the backups goes before you can actually use the admin. (or something like that :confused:)
Having huge files in your backup folder (mine were around 25MB a piece, I think), could indicate you have the same issue as I had.
Next, I cleaned up excessive files in the media folder … and my backup files shrunk in size; logging into the admin was fast again. For a while I had the admin mail me the execution time of the backup to monitor it’s progress.
If this does not solve your issue, then I hope someone else can help you soon.

I would prefer that the backups were created when there is no user-interaction with the admin, i.e. when you choose to leave the admin by pressing logout. Or scheduled in the background, but the latter could be hard to program, because of the variety of server configurations out there. There are other ways … but that’s up to the concierge. :wink:

Interested to hear about your ideas about backup - we are looking at ways to make it better. Shoot me a note later when you get a chance :wink: