Recent post visual


#7

Exactly, I totally agree.


Work started on 5.3.3
Pulse 5.3.3 is here! 🚀
#8

#9

That is correct Michael. I was letting @jdloudon know that this had been reported. See here:


#10

Thanks @ezchile for letting him know

About the tag, it appears to be working:

Assuming you are running the latest version, can you send in anymore detail?
Thanks


#11

Weird…I have updated test site to latest release and its not working for me either:

and here is the tags used:

I thought that it may be because the tags were inside a block rather than being in the raw page code, but it makes no difference. Date is still there.
{{recentposts_visual:“2”:“blog”:“false”:“200”}}


#12

…And those are real, not curly quotes? (The forum seems to change them if not used in a code block) So, the following isn’t working?

{{recentposts_visual:"2":"blog":"true":"200"}}

(True, as in no date shown)


#13

I sent a private message to both you and @jdloudon to let you know about the quotes thing (which was what the problem was) I assume you both didn’t receive it?


#14

Ah, just pasted in exactly that and it works!
My eyes are not so sharp as they were…
Thanks very much.


#15

Curly quotes switched off for the forum..

"test"

But always best to wrap any code (including tags or other) in code blocks as best practice :slight_smile:


#16

Awesome. Thanks Michael.

I agree, code blocks are the best practice, but it's all too easy to copy and paste a tag that's written in the forum by another to test, that's where they crept in! (Well, that's the story I'm sticking to, anyway)

:wink:


#17

Same here sadly... :slight_smile:


#18

Allrighty then, all working as it should. Thanks Michael for adding this, its an excellent addition to the system and just what I had in mind. The only possible improvement could maybe be the addition of some way to manage the height of each post box to keep things neat, maybe using Flex.

Of course the proper way to do it would be to make sure that images used are all the same dimensions, and coupled with a limit of characters displayed this would ensure consistency.
But a lot of clients dont seem to have the skills to be able to size pictures.
Having said that I am not suggesting that Pulse adds big chunks of code to aid complete novices. We must assume a basic degree of understanding principles. I have seen what happens when you make a CMS with complete drag and drop functionality that is idiot-proof. You end up with an unholy mess of code like certain other site builder applications. All of which begin with W.
I am all in favour oof keeping Pulse the lean mean machine.
Cheers/


#19

As in, you were able to make it display the image for a post which didn't have one set as featured image? If so, how? :face_with_monocle:

After the 'curly quotes' thing, I may have missed something...


#20

Yes, I have created a test blog, each with some text and a single image. Then made a block containing our code above. Nothing further was required for it to work here:


#21

It should auto scan for the first image and pull that in :slight_smile:
I think the "/" you mentioned is as you have it installed in a sub-folder? e.g. /pulsecms5/

@jdloudon has it in the root so that seems to be working .. we'll add something to make non root installs work with this.

@jdloudon - glad it is working for you! In terms of styling, that recent post visual layout is already using Flexbox so feel free to amend the CSS to your liking.

You're right regarding the images. Maybe for now it's best to recommend to the client to pre update the images to the right side or go to /media and use the Crop feature inside there?

The last value "200" is the word count limit.

Thanks - us too :heart_eyes:
But let us bear in mind how to improve on this..


#22

Well, I am testing on a MAMP stack, I'll try on a server. It would be great if both would work! :heart_eyes:


#23

Ok, so that is working on a server, which is great!

Also, I've just noticed that the quotes appear to be optional!
{{recentposts_visual:2:blog:true:200}} Seems to work as well. :confused:


#24

Glad it's working!

Yes the quotes are added for readability but are optional (there's a note in the manual about it)

They were added as without the longer tags such as the Blog might be unreadable.


Work started on 5.3.3
#25

This is now working and will be in 5.3.3 :+1: :


closed #26

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.