Sub-pages not available on new install


This is actually a followup to a thread at the old forum.

I am running apache2. I get the same admin/diag.php message about sessions that santi reported on March 7.

`If sessions are not working properly, it can cause problems with logging in and viewing blocks, etc.

Your hosting supports sessions’); } else echo(‘Your hosting does not support sessions’); } else { $_SESSION[‘atest’] = ‘yes’; echo ’

Please wait… '; } ?> `

I also get a 404 when clicking on any of the default/demo nav links at top right corner.

Any clues for me?

More information.

I have pulsecms installed in /var/www/html.

It is served with apache2. I think a standard Ubuntu 14.04 install.

session_module is enabled

LANIPADDRESS/index.php loads great. As does LANIPADDRESS/admin

LANIPADDRESS/about does not (same with work, contact and blog). I get a system 404 not found error page instead.

I’ve tried both with and without “RewriteBase /” in .htaccess.

I’m still told by admin/diag.php the message about sessions in my above post. phpinfo() says session handling is enabled. session auto start is off. there’s no value in session cookie_domain.

Anyway, I figured maybe it is path related problem. Install instruction (and diag.php) says “blank space” for path variable when in tld, which could be interpreted different ways (space or no character) and I’ve tried both, same problem. I also tried in subfolder with /subfolder as path variable. no luck.

One other thing, I tried editing the about.txt page and the edit box did a weird zippy-do animation and displayed the about.txt content as it was before I made changes (i.e. losing all my edits).

So, looking again at my files/directories, I see that they match permissions suggested by diag.php. But my files are owned by my user and their group is www-data. But the group doesn’t have write permissions. So Apache2 doesn’t have write permissions.

Amazing how software can make a fella feel so stupid. I changed content/pages/about.txt to 664 and the admin/index.php could now edit the about.txt file.

But world/everyone has read privs (d 755 and f are 644) what have I done wrong so that apache can’t “find” that about.txt file?

all best,

Thanks @izzaboo - so it’s still not editing the about.txt? Or after changing the permissions it’s all OK now?


Well hello!

So I could maintain the 755 and 644 permissions, I did

chown -R www-data:www-data /var/www/html.

So apache is the owner of all the files and directories. In this situation I can edit, via /admin, all the blocks and files and whatnot.

However, the urls in sb_nav.txt block (e.g. /about) are still resulting in system 404 file not found error when clicked from front end (e.g.

Another hint that maybe I’m having a path-related problem is the images in default blocks (e.g. about-left.txt) are not found (but I can delete and re-insert from file chooser).

one half success!


all best,

This topic was automatically closed after 24 hours. New replies are no longer allowed.