Uploaded 5.3.8 and got...nothing

I have a test site running 5.3.7 so today i tried to update using the update button in settings, which I normally distrust.
So it found the files and then led to a blank screen.
Okay - its broken it. So I deleted the entire site via my Plesk file manager and then uploaded a new set of file.
Hit admin/install.php and it went through the routing of counting down, then I got a blank screen again.
And yes I am running PHP 7.
Any ideas on this?

Hey @jdloudon, we're looking at the issue on the blank page after update. Just to confirm, does the test site you're running have any customizations yet?

As for the fresh install, did you try to clear your browser cache? Clearing just the site data doesn't seem to be enough. The browser history and cache has to be cleared as well, atleast for me.

1 Like

Hello, I have done a fresh install with the new files only. I have also cleared cache and it still doesnt work.
Is this a new issue only with 5.3.8?
I shall wipe it and reinstall 5.3.7 to see if that is okay. I have a clients site that I really want to get upgraded to latest version - its still on 5.2 at the moment but I have had so many isses lately that I am inclined just to leave it where it is.

I have logged an issue in our GitHub page about the built-in updater redirecting to a blank page after clicking the Update button, which is strange since it works on other machines but not on my PC and laptop. We're gathering some more information to work on a proper solution so any inputs would be much appreciated.


It's not only that the updated leads to blank page...it's all blank page. Site not working at all. Even admin pages.

Did you ever look at PHP error logs?

Yes, just had a look. Here is message from today>

AH00126: Invalid URI in request GET HTTP/1.1 HTTP/1.1

AH02032: Hostname accademiafisarmonicistica.com provided via SNI and hostname mazy.online provided via HTTP are different

where the heck is accademiafisarmonicistica.com coming from?

edit: so I just deleted the whole thing, every file using direct server commands, not ftp.
Then uploaded 5.3.7 and did the admin/onstall.php routine.
Worked fine.
Did the same again, deleted all files, uploaded 5.3.8
And its this again:

This page isn’t working

mazy.online is currently unable to handle this request.


Its not my server that is the issue. Something very wrong with this new version of Pulse. As much as I dislike Wordpress and its ways - the updates always work. I have clients asking my why I bother with Pulse when it gives me so much grief. Beginning to wonder....

These aren't PHP error logs. These might be logs from the (Apache) web server.

This version runs smooth on other servers.

Could you please have a look at the correct logs?

I am having this issue on brand new install. I am using A2 Hosting. I have a main domain running a Rapidweaver site (no pulse there yet). I created a subdoamin yesterday. That directs to a subfolder of the over all site. This is where i placed Pulse. I have chatted several times with A2 just to make sure I setup the subdomain & everything has caught up to the new domain.

For Pulse, I have tried the following.

  1. I unzipped on my Mac. Then uploaded via Filezilla, including the .htaccess.
  2. I deleted the folders/files on the server & uploaded the zip. Then extracted directly on server.
  3. I have edited htaccess with all the variances in the troubleshooting guide.
  4. I have wiped the install & re-uploaded (just to undo all the straw grasping I was doing in htaccess.

I have enabled php logs in cPanel & ran install. This is the error that displays after the countdown ends & normally get a blank page.

Fatal error : Declaration of pulsecore\store\page\Item::load(string $filename): pulsecore\store\page\void must be compatible with pulsecore\store\Item::load(string $filename): pulsecore\store\void in /home/exposedp/prototypetest/pulsecore/store/page/item.php on line 7

If I try to launch the admin portal, I get this error:
Fatal error: Uncaught LogicException: Unable to find configuration file in /home/exposedp/prototypetest/pulsecore/dbc.php:14 Stack trace: #0 /home/exposedp/prototypetest/pulsecore/wedge/config.php(274): pulsecore\invariant(false, 'Unable to find ...') #1 /home/exposedp/prototypetest/pulsecore/wedge/config.php(316): pulsecore\wedge\config\load_config('/home/exposedp/...') #2 /home/exposedp/prototypetest/config.php(72): pulsecore\wedge\config\wedge_config() #3 /home/exposedp/prototypetest/index.php(7): require_once('/home/exposedp/...') #4 {main} thrown in /home/exposedp/prototypetest/pulsecore/dbc.php on line 14

When I look at the unzipped directory - I am seeing MacOS "markers" although I never unzipped the file on my macOS. I downloaded from dashboard to macOS. Uploaded to server via Filezilla. Then extracted the file directly on server. I am providing screen shots of what I am talking about. Note the MacOS folder in the main folder. Then in the admin folder note the .DS_store files.

Since I am brand new I am not sure I can try to install an older version or not or where to find it. Just to see if older version works?

I have spent hours. So I think the longer I just poke around the more I fear I am either making it worse or just running in circles. The instructions are pretty fool proof though. Upload, run install, log in. The troubleshooting guide is helpful, but I cant find really anything that fits the issue or trying any of the steps - regardless if I knew they needed to be provided or not - i tried.

Any suggestions, comments, places to look & check, etc... would be great. Thank you!

Here is the root folder since I could only post 1 image, for being new & all.

FYI - I found & downloaded 5.3.6. I installed it. But I tried a different location as well on the server. It installed & worked just like the installation video.

The new location was in the subdomain's public_html folder. So perhaps that is causing apache & pulse to get long better, but not sure. As I had to change the subdomain's landing director in all instances.

I will see if I can upgrade to 5.3.8 a little later. But I wanted to let you know that bit of info.

I updated to 5.3.8 & same result. blank white page after install.php is kicked off. No admin console loads.

So I wiped the directory again. This time uploaded 5.3.7. I had thought the version history was inclusive of the latest. But realized after the fact the latest is top of dashboard & older is in the version history. I screen shot the health check after 5.3.7's install.php finished.

extracted the zip file, ran install.php, go the health check page. Admin console works just fine. So something is off with the 5.3.8 version. I am attaching PDF that shows the 5.3.6 to 5.3.8 upgrade process. I added the zip file, then got a listing of the file contents, and then update button.

Yes, my mistake, they are indeed Apache logs. I cannot find any way to see PHP error logs.
However, the fact remains that every version of Pulse has run okay on this server up until now. I have had issues before but never a total fail like this. Server is a VPS running with Plesk 12 management, lots of memoery and disk space. It is quite strict on security and I have had some some software that required me to change firewall settings, but unless somethinng new has been introduced into 5.3.8 i dont think thats an issue here.
It may well run on some other servers, but clearly not all. So what has changed in the program that could cause this?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.