Advice for Importing a Blocs site into Pulse5 CMS

Hello Pulsers. I'm a newbie, so please be gentle with me, as I am on a steep learning curve here.

I've created a site in Blocs 2.5.2 that I now want to import into Pulse5 CMS. I've already created a test version - which is online here – that works fine. Now I need to add the content management and blog features, so have specified the areas of text, images etc., that I want to be able to amend using Pulse CMS in the Blocs app.

I decided that I wanted to test the site locally before uploading everything to my ISP. So following the instructions on a Pulse CMS video on YouTube, I installed MAMP on my Mac. Then I placed a copy of Pulse5 CMS in the localhost folder. From the Blocs app I chose Export > Export As… > Pulse CMS Theme > Pulse 5. This generated a folder containing "content" and "template" folders, which I dropped into the Pulse 5 CMS folder and replaced the original ones that were there.

Using my default browser - Safari - I then went to the localhost, which displayed the homepage. As you can see from the screen shot below, I see some of the site, but not all of it. Links to some JPGs, PNGs and SVGs appear to be broken.

When I click a link to go to a different page in the site, the browser shows just a white screen. I noticed in the URL bar, there is a lot of tech info between the folder and page paths. It reads:

localhost:8888/pulsecms/%3C?php%20$path;%20?%3E/design

Once I removed those characters from the URL, so it reads "localhost:8888/pulsecms/design" the page loads, but still the links to JPGs, PNGs, and SVGs, are broken. Although backgrounds images displayed fine.

In summary, what am I doing wrong? I feel that it's either the export or import process that I'm not doing correctly that is causing this problem. Or have I not set up MAMP correctly? Any thoughts you may have would be gratefully received.

Thanks! :slight_smile:

Today I’m a little further forward after reading and following the advice in this previous thread.

Using the default Pulse 5 CMS files, I can log into the Control Panel and see the pages as they are supposed to look. Hoorah! However, when I log out of the Control Panel and try to view and test the site like an end user, I get 404 errors whenever I click on a hyperlink.

For example if I tried to go to the Work page, the URL reads: localhost:8888/Pulse5/Pulse5/work

As soon as I remove one of the Pulse5/ subdirectories from the URL in the browser, the Pulse 5 work page appears.

What have I now done incorrectly to cause this to happen? Can anyone advise me please?

I’ve spent yet another day trying to get Pulse 5 CMS to work with my Blocs app website. I’ve followed YouTube video tutorials - several times – and which didn’t provide the solution. I can’t believe that no one hasn’t run into the same issues that I’m having. Strangely I download Pulse4 and exported my Blocs website as a Pulse 4 theme. I had more success getting that to run – although it still had some broken links to image files – than I’ve had with the Pulse 5 CMS solution. As this isn’t working I’m now looking at other content management systems.

For anyone following this thread, Michael came back to me yesterday on a comment that I’d left under the Pulse 5 installation video on YouTube. He told me to download the Beta version of Pulse 5.1 as this had already fixed the 404 page error problems I was experiencing. I’m still rather confused in how I was supposed to know that. I don’t recall getting an email from Pulse CMS or seeing a tweet that informed me of that information.

This morning I went to the Pulse CMS website to log in and download the Beta as instructed, only to find that the site cannot be reached. That could because the URL being displayed is www.www.pulsecms.com. I’m starting to feel very unlucky with this product. :unamused:

Hi Derek,
I can almost feel your frustration with this project. Let’s see if I can make things a little better for you.

Although I own Blocks I must admit that it isn’t a core part of my Pulse workflow so I may need to refresh my memory on certain things. I think some of the issues you are having are down to a mismatch in settings between your Blocks site and the test site you’ve set up in MAMP. For example in your screen shot I can see that the site is in a pulse_cms directory which may suggest why the images aren’t getting loaded correctly. You can adjust this in the Pulse settings (account > settings > general > path) so Pulse knows that it is running in a sub directory.

Generally I like to set development sites up on my live server so that clients can see the work in progress but do so using a dedicated subdomain for them project. This will give me a URL in the format myproject.example.com. By setting the site up this way the paths to all of the assets in the site remain unchanged when the site finally gets moved over to the live server. Without this the Redactor editor that Pulse uses will insert the path you’ve defined in the settings in the code for each image which will all need updating when the site goes live. Trust me, it is a pain to find this out on launch day!

The other issue I think you may be running into is the .htaccess file. The .htaccess file is a powerful little file that can tell the server how to process requests from the browser. You’ll often see it used to redirect users looking for old pages, blocking web crawlers and well as a tonne of other fun things. Pulse mainly uses it to provide pretty URLs.

The CMS normally wants to structure your site URLs like this;

www.example.com/index.php?p=about

Code in the .htaccess file takes this URL format and gives us a much nicer looking URL in the format of;

www.example.com/about

Without the .htaccess file in place your home page will work just fine but all of the other pages in your site will typically return a 404 (page not found) error. Pulse ships with a sample .htaccess file simply called sample.htaccess which you will need to rename to .htaccess. The BIG problem for us Mac users is that the period at the beginning of that file name tells the file system that the file is hidden. Your Mac will warn you that you probably don’t want to hide this file as once you’ve done it changing the file back again is a little tricky once the file is hidden. I tend to use the FTP app Transmit which I’ve set to show these hidden files and can easily use to open and edit the .htaccess file.

Feel free to DM me with FTP details of your site and I’ll take a closer look at what could be causing you problems.
Regards,
Tim.

3 Likes

Many thanks for the detailed response Tim. It’s really appreciated. Pulse CMS feels all very new and is quite alien to the way I’ve traditionally worked in the past with Dreamweaver / Muse and Business Catalyst – auto-syncing from local machine to host server etc. So your explanations on what is happening, bring a lot of clarity.

In fairness to me though, I have been following the Pulse CMS video tutorials on YouTube to the letter. That’s why they’re there, right? So I know about the .htaccess file etc. The screen dump I originally included was the result of me following the Pulse CMS/MAMP video. Of course the video hasn’t been updated and uses Pulse 4 not 5. So I wasn’t sure if there were any differences. In that video Michael changes the path name in line 18 of the Config.php file code and “Boom!”, as he says, everything appears. Not in my case though using Pulse 5, but I had more success when I was using Pulse 4.

I’m like you, and prefer to set up development sites that clients can access and see work in progress. At the moment that approach using Blocs app and Cushy CMS works like a dream - see this version of my site – I guess that is because Blocs spits out HTML files and a directory structure that I’m familiar with, and I can FTP them using Transmit. However Cushy can’t provide the Blog element that many of my customers require, hence my investment in Pulse CMS. When I export my site from Blocs app as a Pulse 5 theme I’m provided with 2 directories that I don’t know what to do with, and there seems to be very little online or written documentation on how to integrate these with Pulse CMS.

Today I managed to get around the unreachable Pulse CMS homepage issue, and download the Pulse 5.1 beta. I then white labelled it, so that my customers know its a product that I trust and I’ve chosen for them. More importantly I now don’t get any 404 page errors. So far, so good. You can see my progress here.

What I now what to do is replace the default pages of this site, with the files that were generated by the Blocs app. These are in two folders called “Content” and “Template”. In addition I want to maintain all CSS styles, links to pages, links to image files and video etc. This sounds very simple, but its proving very hard to do. If you, or anyone else, can provide me with some tips on how to do that, then I’ll be a very happy chap indeed.

Once again, thanks for your reply.

Derek

OK great. Let’s try this;

The template folder is going to contain all of the files required for Pulse to display each page. This is essentially the base design of the site - a sort of master page. Make a backup of the files you’ve already FTPd into the Pulse template folder (just in case) and FTP these files and folders into the directory. If you refresh your site now you should see the existing site content with the new design you created in Blocs.

The content folder contains all of the page, blog, blocks and images (media) that make up the content of your site. Again FTP this whole lot into place into the Pulse install. Again make a backup of the old data if you’ve changed or added anything from the initial install.

Again refresh the site and you should see your new site design with the new content you defined in Blocs.

Thanks for the instructions and explanation.

Following them, I opened Transmit and connected to my server.
Then I located the Template folder on the server and FTPed the contents back to my local machine - just in case.
Next I opened the Template folder, that was created by the Blocs app, on my local drive and FTPed the content to the Template folder on the server.
When offered the choice, I chose to replace folders rather than merge content.
I had a quick look in a browser and the cookie policy was in the right place, but obviously the layout, design and content wasn’t correct.
On the server I opened the Content folder and FTPed everything inside back to the local drive - just in case.
Next I opened the Content folder created by the Blocs app on my local drive, and FTPed everything to the server. Again I chose to replace folders rather than merge.

What I now have is a complete mess. From what you told me yesterday, it appears that the .htaccess isn’t functioning correctly as page links don’t work, and I’m still missing images. So in summary I’m no further forward than I was about a week ago. Can you still feel my frustration here? I so want this solution to work, but I’m rapidly losing patience.

Any thoughts? For example, should I merge contents of folders rather than replace them? Is that causing the problem?

Derek

Thanks for the detail reply Derek.

Looking at the source code for that page I can see the PHP code in the HTML. This should be getting run by the server which makes me think that the server may not be configured correctly.

If you create a simple plain text file and call it info.php with the following code in it, FTP it to the server, and look at the page with your web browser do you see a long list of information about the server or just the code?

<?php
   phpinfo();
?>

If the server is running PHP (which I would suspect if you’ve had other CMSs running before) then this file should tell you.

If you want to DM me your FTP details I can take a look at the server for you.

Done that Tim and I see the long list of info about PHP Version 7.0.30

I’ll DM you my FTP detail, and would appreciate you having a look. However, that’s not a long term solution for me. I need a product that I can upload and update without having to call on the help of the others.

Sure. Let’s see if we can’t figure out what’s causing these problems.

Oh, before I forget can you delete the info.php file please? It is best you don’t leave these on the server as it gives a lot of information that could be used to help anyone wanting to hack the server.

1 Like

Good thinking. I’ve done that too.

I’ve also re-FTPed the content/media/branding folder back to the server as all the white-labelling on the Admin panel had vanished. Just letting you know.

Was this Blocs site ever set up for Pulse 4 by any chance? I can see the templates Blocs has output are in the older Pulse 4 format (that uses PHP to define the site path). When you exported the site did you export it using the Pulse 5 option?

It looks like either you’ve selected the wrong Pulse version when you output the code from Blocs, have built the site using the older Pulse 4 Blocs integration in the past or that Blocs itself is messing up the tag output.

Hi Tim. Thanks for having a look under the hood of my site for me.

I am going to answer your questions in the thread, rather than replying to your DM, as I feel this topic may be of interest and relevance to others.

To confirm, my test site was created in Blocs 2.5.2. I designed and created a standard site without any CMS areas. I then saved multiple copies of the Blocs file, one of which I applied CushyCMS areas to, and a second that I applied Pulse CMS areas to – changing the Blocs Project Settings of each file to the correct CMS.

To elaborate further, in Blocs I selected elements, then used the right mouse button contextual menu to select CMS > Wrap in Pulse CMS Block. The Pulse CMS version of my site was then exported using the Export > Export As > Pulse CMS Theme > Pulse 5 command.

I only attempted to export my site from Blocs as a Pulse 4 theme earlier this week, when I downloaded Pulse 4 CMS from the site and installed it on the server. As I mentioned earlier in this thread, I had more success with that solution, although some image links were still broken.

What is becoming very clear to me, is that Blocs 2.5.2 and Pulse 5.x CMS currently don’t talk to each other. This is a real shame. I believe this combined solution is a viable option for those of us who have been left high and dry by Adobe killing both Business Catalyst and Muse.

1 Like

A quick update for anyone following this thread. Norm, the founder of Blocs app, is now aware of the problems I’ve been experiencing with the Blocs & Pulse 5.x integration. He told me at the weekend that he would investigate and come back to me when he’s discovered what the issue is. So it looks like a solution or a fix might be on its way.

1 Like

This looks like a simple fix that can be tweaked to make this work. And yes it’s the perfect replacement for the Adobe workflow. Hang on and updates on this shortly :slight_smile:

1 Like

Many thanks for this explanation on how PulseCMS does things :slight_smile:

1 Like

Great! I’m glad to read that this particular issue is going to be resolved soon Michael. It’s been almost 6 weeks since I invested in both Blocs app and Pulse CMS, and although they work fine individually, they’re currently not playing very well together :disappointed_relieved:

I’m desperate to go back to my clients and showcase this whole solution to them very soon. So I’ll be keeping a keen lookout for announcements.

1 Like

Just seen this post from Norm on the Blocs Forum. It appears that us Blocs / Pulse 5.x CMS users will be able to move forward again from tomorrow. Thanks everyone for your advice and assistance with this matter, it’s truly appreciated.

1 Like

Fixed in Blocs 2.6.0 BETA 6 Build:
https://forum.blocsapp.com/t/blocs-2-6-0-beta-build-6/3858 :slight_smile:

Glad that they are back in sync - it’s a wonderful combo :star_struck: