Blog Import Error for simplexml_load_string()


#1

I’ve made several attempts to import this blog feed: http://www.ptbump.com/wp/rss I’ve also used http://www.ptbump.com/wp/feed.

Both give me a page full of errors. Here’s a screenshot. Help is appreciated.


#2

Can you share the WP content?

Is the Blog on this page?
http://www.ptbump.com/wp/

That seems to be private…


#3

Even when the WP site is live (which it is now), I’m getting the same error. I was able to put the feed into feed burner successfully. I sometimes get a new page with the error text below.


#4

Thanks @Speedbump - so some pages are going through?

  • How much content is ported?
  • We no longer have a WP specific importer as it was too difficult to cleanse all the data. WP has so many unique setups that we couldn’t process all the edge cases.
  • Have you also tried extending the page variable on the importer setting?

#5

no pages go through. It doesn’t import anything. I’m wondering if it’s because the wp-content folder is still in the root file but the WP site in a sub directory. I’ve had a lot of problems with this server and having to move the WP site and set up a new site, etc.


#6

Yes it could be that… and WP gets its knickers in a twist in different directories.

Other options:

  • are you a RapidWeaver user?
  • did the feed burner link in the Pulse importer show any better?

#7

I am a RapidWeaver user, but this site was built with blocs 3. Feedburner link still failed again saying there is an error in blog_import.php line 454.

Is there a way to do this with the exported xml file from the original WP Site?


#8

OK - was worth checking. As @instacks has a Poster Stack importer in BETA for WordPress blogs that might have worked for this.

Not automatically, that would require copy and paste by hand and you have so many blogs!

Can you go to Admin > Settings > Extend > Logs and attach your logs to see if we can improve the importer for your case? Thanks


#9

Would it be easier & more effective to give you access to the site? The end user is my brother and I know he’s ok with it also.


Pulse 5.3 is here 🤩
#10

Thanks @Speedbump

  • The simplexml bugs seem to be around malformed xml.
  • That seems pretty usual for RSS/Atom feeds.
  • It looks like this is a variant of Atom, so will need a special case to handle in the code.
  • We will need to add an exception for this in an update.

It’s relatively easy to do, and we can do our side, just a little time consuming for the testing. So it will be in the next update.

The two feeds /feed and /rss seem to be the same content so its case of testing against that and seeing what happens.

If it’s time sensitive, maybe import the latest 10 posts manually to get the site up and running and we’ll update you on this for the next version.


#11

@Speedbump

The wordpress blog import now has a unit test in the next version.

That works without errors for a saved version of http://www.ptbump.com/wp/rss

There are some character encoding problems though. I’ll try the manual import next and see what that does.

http://www.ptbump.com/wp/rss and http://www.ptbump.com/wp/feed seem to have the same content.


#12

That’s great to hear! Amazing Work!


#13

The manual blog import works from http://www.ptbump.com/wp/rss

There are some character encoding problems here and there. There are no SimpleXML errors or warnings either.

I’ve had a close look at the code and I don’t see what could be causing this.


#14

Can you help me understand what you mean by a manual blog import and how I could possible do it?


#15

Yes, the manual import is via the blog import in the admin area :slight_smile:


#16

OK. I was thinking that was more of an “auto” import. Manual is me copying and pasting stuff :joy:. Thanks for all your help. I’ve got his site and blog functioning great now and ready for him to use. Thanks so much for your product and the support behind it.


#17

This is great to hear @Speedbump :star_struck:


closed #18

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.