Pulse 5.2.1 and Blocs 3.0.6


#1

Hi. Recently my internet service provider broke my derekdigital site :disappointed: which I built with Blocs 2.x and PulseCMS 5.1 - and got to work with a lot of help and advice from @pulsecms and Norm at Blocs app.

So yesterday I thought it was time to fix the site using Blocs 3.0.6 and PulseCMS 5.2.1. I decided to do a fresh install of PulseCMS - after taking a backup of the original site :wink:

White labelling and installation of Pulse CMS went smoothly, and after doing a few modifications to my Blocs file, I exported my site as a Pulse 5 theme. I then transferred the files in the content and template folders generated by Blocs to my Pulse site. I then returned my blog txt and jpgs - from the backup I made - to the new Pulse site too.

I launched the site and the home page appeared as expected. Yay! But then I found none of the navigation works. Pages cannot be found :disappointed: Everything is there, because I can see it and amend text and images via the Pulse Admin Dashboard. It’s just the pages that don’t appear. However links to external sites, that I’ve added in the footer of the home page do work.

I’m sure there is a simple fix for this. My question is how? I’d love get my PulseCMS/Blocs site up and running again asap. Thanks! D


#2

htaccess is correctly installed?


#3

Hi. Thanks for the suggestion @instacks.

I followed the instructions on this site and got the internal server error message. So it looks like everything is correctly installed.

I’m going to strip out the navigation in Blocs app and rebuild it, to see if opening a 2.x document in Blocs 3.0.6 caused the problem. Norm at Blocs app has also asked to have a look at the file, so will send to him, if I still can’t get things to work.

But reading recent posts on this forum, it appears others are using the same versions of PulseCMS and Blocs are getting things to talk to one another.


#4

Thanks @DerekDigital

Yes it seems issues in Blocs3+Pulse5 were fixed in 3.0.5 - this was to do with the exporting of templates.

But sounds like you have a different issue and others are running their sites again.

That said, please let us know what happens and am sure Norm will add any adjustments in the next update.

Have you tried going to your Pulse admin and saving settings again?


#5

Hi @pulsecms, I’ve sent my file to Norm at Blocs for him to have a look at. It’ll be interesting to see if he can put his finger on what is going one.

So I’m afraid I’ve removed Pulse CMS from my machine for the time being. I’m not sure whether it is an issue with my ISP, or the way software apps interact with one another, but something clearly isn’t working. Instead of spending more time getting frustrated, I’m going to take a break, and come back to it fresh in the new year.


#6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.


#7

#8

Sorry to hear this @DerekDigital - the updates on Blocs app recently might have helped this?

We’ve also just released a new version you might try:

There are others having success with Blocs - maybe try this process?


#9

No - the blocs 3 export is still broken…


#10

Hi @Raimo
I don’t know why, but my projects with pulse and blocs work. Did you use special brics or something else ?
When it helps you can send me your blocs file and I give it a try on my test sever …
tom


#11

@tom2 I just messaged you with links to both the Blocs Project and the Exported Pulse files. There are other Blocs users also having this issue…

Thanks!


#12

@tom2 While we are on the subject of Blocs and Pulse

  • do you know how to reference “Pulse Blocks folders” when using Blocs 3?
  • or how to add “Pulse tags” in Blocs 3

I had asked these questions on the Blocs forum and on this one, but never got replies from anyone.

thanks!


#13

Hi …get it to work …send you a email …
tom


#14

Hi …
sorry, my English is not so good. What do you mean with “reference” Pulse block folders ?
And I don’t use tags … What I do is only to use the blog system for client and set some text blocks so the client can change the text …
sorry :blush:
tom


#15
  • do you know how to reference “Pulse Blocks folders” when using Blocs 3?
  • or how to add “Pulse tags” in Blocs 3
  • you mean blocks inside folders?
  • Pulse tags are most likely needed to be added after publishing the site (in the Pulse admin)

Did you contact Blocs support and ask them to check the error of content loading into the “title” tag?


#16

Okay, been playing with it, and at least I can get the site to load now using @tom2 suggestions

  • make sure there is both a “Page Name” and “SEO Title” for every page in your Blocs 3 project

And in the Pulse 5 Project “export” settings

  • “unclick” Minify HTML
  • “unclick” Minify Main CSS
  • “unclick” Enable Lazy Loading

So at least the exported files now work with Pulse 5

I also figured out how to add Pulse compatible “Blocks” that can be nested in folders

  • don’t use the Blocs 3 “Pulse Bric”
  • instead use a “HTML Widget” and put in the regular Pulse tags for your blocks {{block:folder-name/block-name}}
  • AND this seems like it will also embed whatever other Pulse tags you want. I tried it with a Pulse {{masonry:galname}} “tag” and inderneath it, a {{justforms}} “tag” (Pulse 5’s advanced form builder) on this test page

Now what still doesn’t work is the “on-screen editor”, no little pink boxes… Something else is still getting over-ridden when exporting the Pulse 5 project out of Blocs 3.

One other note - by using “Pulse Tags” inside of HTML Widgets instead of “Pulse Brics” - all content editing is done through the Pulse 5 Dashboard.

  • When you upload any page changes from Blocs to your Pulse install, you only need to upload the “Template” folder, and the “Pages” folder inside the “Content” folder. That way you never worry about wiping out any changes that were made by you, or your client.

I am going to post this as well over on the Blocs forum