Pulse 5.3.1 {{recentposts_visual}} - Issues


#1

I’ve found a couple of bugs and reported them on Github, but have worked out a quick fix for one of them in the meantime.

This works for me, but your mileage may vary. Please ensure that you back up the original file elsewhere, so that you can easily restore it in case this doesn’t work for you.

I found that if I try to use the {{recentposts_visual}} tag ( I.E. something like: {{recentposts_visual:“6”:“blog”:“no_date”:“200”}} ), the blog headings didn’t seem to point to the blog articles they refer to.

I found that in the file /pulsecore/template/tags/recentposts_visual.phtml if you modify line 7

From:
<h3 class="recentposts_visual_card_title"><a href="<?php echo $view_model->base_url; ?><?php echo $this->escape($value->item->get_location()); ?>"><?php echo $this->escape($value->item->title); ?></a></h3>

To:
<h3 class="recentposts_visual_card_title"><a href="<?php echo $view_model->base_url; ?><?php echo $this->escape($value->item->relative_url); ?>"><?php echo $this->escape($value->item->title); ?></a></h3>

It seems to solve this issue. I know that this is just a temporary fix, but it may be of use to some until the Pulse team are able to fix the issue in another way.

This only appears to work with posts without images, as the {{recentposts_visual}} tag also tries to insert the first image in the blog post (which doesn’t work for me as it appears to ‘break’ the tag it’s inserting) but that is a bit beyond what I’ve been able to work out, sadly.


5.3.2 is getting ready!
5.3.2 is getting ready!
#2

I think this has been posted here?

Thanks for reporting and the temp quick fix for now :slight_smile:


#3

Yes, I reported that on Github Michael, but thought that the ‘Quick fix’ may be more useful here. :crossed_fingers:


#4

Thank you, @pulsecms and @ezchile, this works fine for me! I tested it and it works great. Exactly what I needed …:smiley:


#5

Great to hear that this worked for you Annett. :relieved:


#6

For me, the page show the title of the post. And no image.
In addition the linked title goes to an error page because the file path is wrong.


#7

Is that after changing the line I mentioned? It’s a root install for me, so maybe that’s the difference.

Images are definitely broken and the path needs looking at. I’ve put a bug report on Github, so hopefully this will be sorted soon enough.


closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.


#9

Fixed as per your suggestion @ezchile - thanks and will be out in the next release :slight_smile: 5.3.2