Error message using built in UPDATE option


I was running 5.2, and downloaded the 5.3 update. I have Pulse installed in a subfolder from the main site root, /pulse.

When I use the 'Update' facility in the settings area, I get an error:

the script is being redirected back to the root, rather than the /pulse/ folder in the root...

In my debug log, I have the following error message:
[28-Sep-2018 21:30:25 Europe/London] PHP Notice: Undefined variable: _GLOBALS in /Users/Junction10/Desktop/KMP-Test/pulse/pulsecore/page/admin/update.php on line 104

Line 104 of that script shows:
\header( 'Location: ' . $_GLOBALS['path'] . '/admin/index.php?p=update' );

Should that underscore be in the $_GLOBALS in that line?

I'm not sure if the update has completed correctly because in the settings page - it still shows 5.2 in the version number, and the folder _MACOSX that has been extracted still exists under my /pulse folder...



Thanks @junction10

Do you mean 5.2BETA1 and update to 5.2BETA2?

This is the latest:

Yes it needs to be in the same folder. I would recommend taking a backup before doing an update.

But the update has been tested and works well.
That said, will need more testing in sub-folders but it should be fine.

Can you DM me your logs as well?

Ahhhh… ok - the version number is my mistake… It is of course 5.2 BETA 3… I was upgrading from 5.2 BETA 2… so the version number IS correct (could I suggest including the beta build version in the Version descriptor on the settings page too… eg: 5.2b3 ?

5.2 Beta 3 is the latest build, not beta 2 - correct?

I’ll send you the logs in a moment… that underscore in the $_Globals variable definitely causes an error though… I changed it to $GLOBALS and the update went ahead without any error… (I hope! It does seem to work, anyhow)…



1 Like

Thanks - we’ll look into this :slight_smile:
And any fixes will be in the next update

Thanks for the logs!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

This was fixed in 5.2B4! :slight_smile: