Work started on 5.3.3


#1

Following on from the 5.3.2 release, we've already started on 5.3.3 :star_struck:

You can see some of the issues that will be tackled here:

If you have any, feel free to add them in there but we hope to update this as soon as we can.

Things done already (and more will be added to this list as we go):

Pulse 5.3.3

NEW

IMPROVEMENTS

FIXES

  • Dropzone upload icon back for Font Awesome 5
    https://github.com/yuzoolcode/pulsecms-tracking/issues/106
  • Fix for Sweet alert error X image
  • Hide bullets in Pages META
  • Ecommerce / Shop table headers fixed to one line
  • Better handles leading slashes in image URLs for {{recentposts_visual}}
  • Fixed the Media Gallery sub folder sorting bug
    Suggestions for 5.3.2
  • Plugged in a fix for showing audio/media files in the media folder
    Work started on 5.3.3
  • CSS fix to ensure bullets appear for unordered lists in Editor mode
  • Fix for editor adding blocks now adds the block to the editor block ACL list

(updated..)


Other notable things to be tackled if possible include:

  • updates to media sorting
  • further reducing the size of the install package
  • better way to add featured image
  • lots of testing..

More announcements to made shortly so keep on Pulsing and keep in touch :zap::heart_eyes:


Suggestions for 5.3.2
pinned globally #2

#3

Maybe an idea for embedding videos:
In my new student newspaper project many videos are to be integrated. I would like to sort them into folders, like the pictures. Unfortunately, videos in folders are not displayed, only in the first level - in the media folder itself.
Is that possible?
many Greetings
Annett


Pulse 5.3.3 is here! 🚀
#4

They should be viewable in sub folders too - that will need to be amended. Thanks for info on that :slight_smile:


#5

A few ideas / requests from me...

  1. I'd really find the ability for blocks (both super and normal) to have a tickbox (default to on) as to whether they are published (visible to users) or not. That way you can create blocks, insert them where needed in an unpublished state and then toggle them to published when you are happy with them.
    Maybe blocks in unpublished mode could show for Admins who are logged in, but at .5 opacity or something, to aid placement and development?

  2. If toggles for published / unpublished blocks become possible, would the same be possible for blog posts and pages? I understand that naming a blog post with 'draft' appended sets it to draft mode, and renaming the article to take it out of draft mode is possible, but a checkbox would be so much easier and nicer to use. Also, the ability to set pages to be able to do the same would be great...

  3. The 'Settings / Extend' menu holds a few items that feel strange to be in that menu for me. Custom Post Types, User list and Commerce feel like they need their own separate menus, rather than being held in a menu that sounds like it was meant for something else.


#6

Great:+1 @pulsecms :
And again a request:
The new feature {{recentposts_visual: "3": "blog / subblog": "true": "150"}} is great and I like to use it. But if I have ## more ## before the 150 characters are over, that will not be translated. Can this be changed so that ## more ## works in this variant as well?
Screenshot_2019-05-09%20Hallo%20und%20willkommen
(Maybe that has already wished someone else, then sorry for duplicate entries)
Many Thanks
Annett


Pulse 5.3.3 is here! 🚀
#7

Good point Annett.

To add to this @pulsecms, could the cut off take into account the last word. At the moment, it counts the characters and chops at exactly that length. This needs to be done a little more thoughtfully, so that you don't end up with half words. For instance:

Consider 'The quick brown fox jumps over the lazy dog'

If a limit of 36 was specified, the output would be 'The quick brown fox jumps over the la' which makes no sense.

If the 36th character sits within a word, then if should truncate the word that is cut, so that it would display as 'The quick brown fox jumps over the...' If this brings the actual character count below the length threshold, that's fine - At least the output would be clean.


#8

Absolute :+1:. You're right @ezchile . The function of ## more ## could be the same in recentpost as in the "correct" blog preview.
I always stumble over pasted {{gal: ...}} tags, which are then truncated in plain text ... :upside_down_face:


#9

Thanks for those - have noted your 1 and 2 for a future update, but not at this time :slight_smile: But makes sense so will bear in mind for a release soon.

That's because it's evolved since version 5.0 and "power" features were meant to be in there - as not all users require these features. That said, we're already considering to move some items around so thanks for this feedback. Again though, won't be 5.3.3 but will bear in mind for a version down the road.


#10

Good thinking @annett and @ezchile - I think we can add word-wrap to the truncation in recentposts_visual and also somehow exclude readmore or other tags.

We'll see what we can do for this time :slight_smile:

Also - please note the great new read more add-on by @IvaRo


#11

Another wish:
if I have a video in the Media folder and click on it starts video immediately. Is it possible to open videos like pictures so that I can see and copy the link - for embedding? Maybe add a title tag - for the future ...?
Many Thanks


#12

And again me... @pulsecms
It goes back to recent_visual and galleries (had the problem ever addressed - sorry - it is not resolved):
I have a gallery {{gal: testgalery2: 1: yes}} at the beginning of a blog post (save me the featured image).
On my homepage I load this post.
But in the frontend, I can not handle the gallery properly ...

I've seen through everything, my source code is clean and structured. I upload the same gallery via blog show or directly to the page everything works perfectly. I think it is not a mistake of mine.
To make it clear that the problem lies in the recent_posts tag, I've created a few simple test pages - the title says the content.

https://www.junge-blogger.oggym.de/test-with-gal-only
{{gal: testgalery2: 1: yes}} (works)

https://www.junge-blogger.oggym.de/test-with-blog-show-and-gal
{{blog-show: test2: [[blog-contentloop (<< blog-item-author >> << blog-item-date >> << blog-item-title >> << blog-item-content >> )]]}} (is working)

https://www.junge-blogger.oggym.de/test-with-gal-in-recentpost
{{recentposts_visual: "3": "blog / test2": "true": "150"}} (does not work)

https://www.junge-blogger.oggym.de/test-with-picture
{{recentposts_visual: "3": "blog / test3": "true": "150"}} (works)

I'm not able to figure out exactly where the error lies - I've already looked at everything. It would be really great if I could use recent_post with gallery at the beginning. These functions give a very nice overview on a start page - certainly not only for me ...
Many Thanks
Annett


#13

This has been added for the next release @annett & @ezchile

  • Truncation is now based on number of words
  • Also with {{recentposts_visual}} tag it now strips pulse tags from a string - also removes ##more##

Word count had some odd edge cases around punctuation. HTML is stripped, but Pulse tags aren't. Now has been all improved. Thanks for the feedback!


#14

So just to be clear...

  • the page here is not working
  • the issue is you are using the {{gal: testgalery2: 1: yes} in a blog post and the gallery is not showing in the blog post?

Let me know


#15

This can be done a future version also, thanks


#16

Hi Michael, that is great news. Thanks.


#17

@pulsecms, thats great, thank you. :smiley:


#18

Hi @michael,
sorry for that - the link works perfect for me. But OK. :woman_shrugging:
Please try this:

  • open a blog post
  • put {{gal: gallery1: 1: yes}} first
  • open pages-> home and add
    {{recentposts_visual: "3": "blog": "true": "150"}}
  • please test the gallery
    I used the Original Pulse 532 templates, nothing changed.
    Maybe it's not meant to work - but it would be fine for me.
    Please excuse the circumstances.
    Many Thanks
    Annett

#19

Thanks @annett - that workflow example is really helpful and can replicate this - we'll look into this :slight_smile:


#20

Thanks @annett: I've retested and {{gal: gallery1: 1: yes}} and it is now being filtered out in the recent posts visual output (as per above - Work started on 5.3.3 changes).

@ezchile That missing "/" was a tricky one.

The url filtering was removing leading slashes in the blog item image extraction code. This is now improved.

Also, the displayed image in the recent post visual items have a max width of 100%, so that should be preserving the aspect ratio.